Jump to content
Corsair Community

Corsair Vengeance M60 half-dead after update

Recommended Posts

Right, so,


About a year ago I bought the Corsair Vengeance M60 Gaming Mouse, I had always updated the firmware whenever needed to and installed the software. All worked fine, up until a few months ago... A few months ago I remember I had to re-install Windows 7 (64 bit) for whatever reason, doing so obviously got rid of all my software. After re-installing Windows 7 I immediately set out to update my Corsair M60's firmware and installed the software required to change the DPi and such. The firmware install went fine, so did the software install. But when I started playing with the DPI, the mouse just died. According to Windows It disconnected, so I had to re-connect it to the USB port. After doing so, I noticed something was wrong with the lights of the mouse. Instead of indicating whether or not I'm on 1 bar DPI, 2 bars or 3 bars, It only lit up the top bar light, and that's it. MOUSE4 and MOUSE5 are completely dis-functional, the DPI can not be changed, neither can ANY other setting within the program, and on top of that, the DPI is on a really awkward number that I'm totally not comfortable with.


I tried plugging it into different Windows computers, but no luck. Eventually I thought, maybe something did go wrong with the firmware update, so I went and downloaded the firmware update again and when I opened it it just gave me this exact message:

`Cannot open USB device! Please plug the device into a USB port or reinstall driver!`

so at that point, I realized I'm just at a loss here, is it a faulty mouse? A glitch that has caused this? Or is it just dumb luck? I have no idea, I also lost the receipt of the mouse so I can't bring it back to the store I bought it from.


If anyone has ever gotten this issue, and has any more information regarding it, please let me know.



Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...