Jump to content
Corsair Community

Blank Corsair Link on B350M Mortar Arctic


juu
 Share

Recommended Posts

I built a new pc a few weeks ago. I recently updated my drivers yesterday. Before that, Corsair Link was working fine and was able to properly configure my Corsair Vengeance DDR4 RGB. After the update, Corsair Link suddenly became like this:

 

link.thumb.jpg.72fb8a8e6dbe2e6ca7ec99fdc2caf1fb.jpg

 

MSI Gaming App also seem to override all the settings I made before the update. Even if I turn off the control over my ram, they are still stuck at the red LED which was initially set by the Gaming App.

Link to comment
Share on other sites

  • Corsair Employees
You're running into a known issue. We're actually working with MSI to allow our software suites to coexist and move control of our lighting devices between them. In the meantime, unfortunately you'll basically have to choose between running the MSI Mystic Light app and Corsair Link.
Link to comment
Share on other sites

I usually leave it running the whole time. Before the update, Corsair Link doesn't even pop up on startup. It stays minimized on the icon tray but the lights are automatically working on my settings. After the update, I noticed it took a while before Corsair Link would boot, then it would open a window indicating it is running. That's when it started to display a blank window
Link to comment
Share on other sites

No ... not the GUI app but the service. Go to your services control panel applet and look for "Corsair LINK 4" service. The description should be "Corsair Link 4 Device Monitoring Service". This is what actually monitors the devices and it then sends the information to the Link GUI. If that's not running, Link won't get any data ... and you'll have a blank screen.
Link to comment
Share on other sites

 Share

×
×
  • Create New...