Jump to content
Corsair Community

ML RGB Pro Fans, RGB Hub and Commander Pro Issue


whiteshadoz
 Share

Recommended Posts

Hi everyone,

 

I have just built a new setup with 6 x ML Pro RGB fans running to a RGB hub and then a Commander Pro. They aren't being recognised correctly in ICUE.

 

I have gone to lighting setup and selected Lighting Channel 1 as ML PRO RGB Series Fans and specified that 6 are connected.

 

When doing this is treats each individual LED as a fan, not the fan itself. Meaning ICUE thinks the 4 LEDs on the first fan and 2 of the LEDs on the second fan are my 6 fans. Meaning 4 1/2 fans aren't lit up (18 LEDS)

 

If in lighting setup I select that 6 RGB LED strips are being used then all fans light up correctly but this will only let me configure the lighting as a strip which it isn't.

 

Quick detail of layout:

 

6 ML Fans connected to 6 ports on the CoPro and the 6 RGB connectors to the equivalent ports on the RGB Hub.

RGB hub is connected to lighting channel 1 on the CoPro.

Sata power ok

All fans are spinning fine and speeds can be adjusted, just the RGB not working correctly.

 

I have tried another RGB Hub and lighting channel 2 and still having the same issue. I have also updated drivers and reseated connectors.

 

Any help would be appreciated.

Thanks :biggrin:

Link to comment
Share on other sites

Can you post a screenshot of the Lighting Configuration tab with this? I’ve never seen anyone else report something like that and we probably need to figure out if it’s a UI glitch or something else.

 

I’m not seeing this for my ML and this is the first report, so it may be a local issue. Go to the Windows settings -> Apps list and select modify for Corsair CUE. Follow the prompts for a repair installation. This will not remove your profiles and settings but tends to clean up weird issues.

Edited by c-attack
Link to comment
Share on other sites

Just tried the repair and that hasn't changed anything.

 

I have just tried a lighting node pro between the RGB hub and the commander pro and all the lights came on all fans but wouldn't let me configure any through ICUE.

 

I guess it could be a fault on the commander pro. It's the only part currently I haven't been able to swap out for another so might have to replace that and see.

 

Seems odd it will allow it when LED is selected rather than ML though.

 

Hoping I'm missing something obvious :D

Link to comment
Share on other sites

If you run the lighting through a Node Pro, then it will become the controlling device and require you set it up as ML x 6 as well.

 

Perhaps this is physical masquerading as a software issue. The lighting is serial, so if something goes wrong on fan #1, LED 3, the lighting stops there. Based on your description it may be fan #2 that is the problem. Try swapping fan #2 and #6 on the RGB Lighting Hub.

Link to comment
Share on other sites

I have just unplugged all the fans and tried every fan in port 1 and they all work. I kept fan 1 in port 1 and tried all the other fans in port 2. It seems to only display half the LED so might be a fault with port 2 itself rather than the fans.

 

Just to clarify something as well please. When I go to ICUE to configure the lighting as the attached pic, it show LED Port 1 as red, 2 as yellow, 3 as green etc. On my fans when configuring it counts the LEDs so Fan 1 LED 1 is red, Fan 1 LED 2 is yellow etc. Does yours do the same when you go to configure or does it show a full fan colour correctly? I assume it would show one LED on each fan that is connected

 

I will try my other RGB Hub again and test each fan again on that and see what shows

Link to comment
Share on other sites

OK, good job. You figured out the next step and I agree there likely is a problem on port #2. Contact Corsair support to see if they can mail you a replacement. If you happened to have bought two triple packs of ML, you might already have a spare. This is one of the reasons I normally suggest people get the multi-packs unless there is a clear difference in price between singles x 3 and triple packs.

 

The Lighting Set-up "dots" are relatively new and besides identification, it helps with the rotation function. It runs Red-Yellow-Green-Blue-Magenta-"Pink/White" and will continue to show the dots in CUE and in the case when you are on the Lighting Set-up.

Link to comment
Share on other sites

Tried another RGB hub earlier, same issue. Ordered another commander pro which just arrived and that creates same issue.

 

Just going to uninstall ICUE completely and reinstall with new copro and hub in place.

 

Can't see any conflicts with any other software as it's a fresh build so nothing else installed yet.

 

Will update shortly.

 

UPDATE:

 

Reinstalled everything as it showed 2 CoPro but currently up and running with the new CoPro installed. Can't see why the old one would have caused the problem but I'll not worry as it stands. Appreciate the support thank you!

Edited by whiteshadoz
Link to comment
Share on other sites

Hmm.. this is getting more complicated. Software conflict is unlikely and doesn't usually present itself in this form. It is possible you still have a bad fan and not coincidentally. The hub and fan may have been damaged together in whatever happened. I would again swap 2 <-> 6 to see if it clears things up.
Link to comment
Share on other sites

 Share

×
×
  • Create New...