Jump to content
Corsair Community

iCue Not working after 3.25.60 update


Sp503
 Share

Recommended Posts

I've been using iCue for a few years now, no real problems. I tried updating it today 2/15/20. Once complete it never launched after the update. I've tried uninstalling and reinstalling iCue and that didn't work.

 

I actually tried restoring Windows 10 to the day before but once that was complete iCue still wouldn't it work.

 

Ive read through other posts and have seen people with the same issue but they never really get the solution or at least post the solution.

 

I've used IOBit Uninstaller to attempt to get all traces of iCue removed before installing iCue again. No luck

 

Ive used IOBit Uninstaller to uninstall Asus Aura RGB software and Asus Armoury and Armoury Create. No Luck

 

When I look in task manager I see some Corsair services running in the background. However, If I launch iCue it shows for a second in Task manger then disappears again.

 

Any solutions? Thanks

Link to comment
Share on other sites

 Share

×
×
  • Create New...