Jump to content
Corsair Community

Corsair 115i RGB Platinum not appearing in ICUE


Recommended Posts

Hi all,

 

Im new to posting here (Made the account for this) so sorry if i get anything wrong and thanks in advance for any help. I currently just built a new pc and cannot get my AIO to be viewable in ICUE. I've tried looking around for a solution but everything i've tried so far has just resulted in nothing new happneing.

 

The AIO is a "Corsair H115i RGB PLATINUM Hydro Series High Performance CPU Cooler". Currently I can control my motherboard and RAM RGB from ICUE perfectly, just not the AIO. Also I can configure and monitor fan speeds and temp from bios and other monitoring software I had to download since I couldnt change it via ICUE.

 

I've tried all the normal steps, clean install of ICUE, changing the USB form one motherboard position to another or to a rear IO etc.

 

A friend mentioned a USB issue so i checked and the AIO isnt even appearing in USBDeview (or im just blind) so im not sure if the thing is even transmitting it in the first place.

 

Any Help would be greatly appreciated!

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...