Jump to content
Corsair Community

Corsair Virtuoso XT buggy/USB-C issues

Recommended Posts

Hey there, got a bit of a situation with my Virtuoso XT headset that I haven't been able to solve for the past month.

What is happening: My headset will lose functionality anytime the USB-C gets plugged into the headset. From what I can see, the headset just goes incredibly buggy and usually requires multiple soft resets to get things to somewhat work.  If I can manage to get the headset charged and kept unplugged, i can get the headphone to function normally with the wireless and bluetooth just fine. When I plug in the USB cord, here is what I can expect to happen now:

(On WIreless and plugged in)

  • Sound dies completely even though the dock shows that wireless is currently in use and the sound settings show the equalizer nex to wireless as active and sound is being outputted.
  • Unplugging wire aftwards does not fix, will continue to be silent until I perform a number of soft resets
  • Same issue happens during bluetooth mode. Sound will work fine but bug out after being plugged in

(On USB mode)

  • Sound will briefly work but then go silent and remain that way.
  • unplugging and replugging in wire will not fix the issue.
  • can only get sound to come back for after a few soft resets and only for wireless mode
  • I have tried plugging the USB in different ports on the PC and on several different devices (laptops, seperate desktop, steam deck) 
  • have checked that I am in USB mode

So far, nothing I have attempted seems to have fixed this. I have seen the wireless and the bluetooth work fine on different devices but continue to get the same errors when using USB mode plugged in. I haven take apart the headset to check for damage but could not find any evidence, I have also swapped out the battery in case the issue had to do with power but the same result occurs regardless of which battery I put into it. I have uninstalled Icue and device drivers multiple times to get it to work. I have forced firmware updates to try and get things to work. 

if anyone has had this problem before, would like to hear any tips on getting things to work again so this headset doesnt end up just being used as a spare set that only uses the 3.5mm headphone jack all the time.

Link to comment
Share on other sites

I just tested all my USB C hardware and none of it affects my headphones like yours. I would return them where you bought them or do an RMA with Corsair.

Or try it with no ICUE installed. Use something like REVO Uninstaller to remove everything after you remove the application.

Link to comment
Share on other sites

1 hour ago, Kontonjuken said:

Well outside the RMA time, will try out the REVO and see if I can get any better results.

That sucks. I wish they had a longer warranty, But a year seems to be the standard now for everything.






I believe the free version only allows you to do a few at a time. But you can simply close it and restart it to continue. Good


Link to comment
Share on other sites

  • 2 weeks later...

Well I tried the REVO and that didn't fix it. As of now, i'm leanig towards this being and issue with the port itself being faulty now since everything else seems to work fine and all the issues seem to be specifically arouond USB-C usage. Pretty much looking like i'll need to replace this.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...