Jump to content
Corsair Community

Corsair Void Elite RGB stopped working (No voice prompts, no Discord sound)

Recommended Posts

Hello, I'm new here and I really created the account in order to find solution to my problem. So I actually love corsair's peripherals and for that reason all my peripherals are corsair labeled.

  So today my Corsair headset (Void Elite RGB) suddenly stopped working as expected. Although I can hear sounds like Windows Notifications, Spotify, Games, YouTube, I do NOT hear discord, I do NOT hear voice prompts (although they're enabled) and i can't hear my voice in VOICEMOD. All of this is so weird. I tried out some things like pair the dongle to my headset and reset my Void by pressing the MUTE button but nothing really happend and I did a clean re-installation of ICUE v4.28.177. Same issue is going on and on. Did anyone had the same issue? How did you fixed it? Any suggestions?

Thanks in advance




Edited by Thanasis129
Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...