Jump to content
Corsair Community

Requesting an old BIOS for Corsair One™ Pro (2017)


willfull
 Share

Recommended Posts

I am in dire need of a BIOS downgrade for my 2017 Corsair One™ Pro (CS-9000011-NA). I'm looking for an early version of the BIOS, one that will allow me to manually set the PEG0 - Max Link Speed back to Gen1. I think I was running either version 4.QF or 4.QQ, and that was the last time my system was running consistently well. I understand there have been major security updates in the meantime, but what's the point of security if my $2300 USD computer is not working in the first place?

 

Here's what happened:

  • A week ago, I (finally) decided to do a BIOS update. I have been running the original factory BIOS version since originally receiving it back in 2017.
  • First BIOS update I tried was version E7A66IZ1.4C1 (aka "the Spectre/Meltdown BIOS Update"), and then a few frustrating days later I installed and flashed the current version, 4C3.
  • For the record, I followed all instructions as provided on your forum sticky, and reset the CMOS after each successful update. (Understand that I've been building and fixing PCs since the '486 days, so this isn't my first rodeo. :biggrin: )
  • Ever since applying the last two BIOS versions, where you invisibly locked the graphic card at Gen2, I've been unable to successfully boot my Pro into Windows without it locking up 4 times out of 5. (At this rate, I fear that I will have to replace the power button.)
  • I'm at my wit's end by this point, since there seems to be no combination of BIOS setting or Windows re-install that will bring me back to stability. If anything, I'd like to just take my system back to its original configuration and pretend none of this ever happened.
  • Note: My Pro is running a clean install off a Windows 10 202H ISO straight from microsoft.com.

I've been through a myriad of BIOS settings, starting with the default optimized settings, and I'm still unable to attain the stability I had before the BIOS update. Cold starting the computer will usually result in a lock-up before the OS is even booted, sometimes a spontaneous restart happens where the Pro powers off and then back on, and even if the Windows login screen does appear, it will usually lock up before I can finish punching in my 4 digit PIN number.

 

I recognize this behavior from a few years ago, before I found the Max Link Speed setting in my BIOS and switched it to Gen1. System ran fine afterwards, booted into Windows every time I switched it on. I know I'm late to the game on getting the PCI-e ribbon replaced (>1 year past warranty), and I'm sure there's a cost to video performance by throttling down to Gen1, but I NEED a working computer now, not an aluminum $2300 desktop conversation piece and angry clients wondering why I'm not meeting their deadline.

 

Thanks.

Link to comment
Share on other sites

Hi there,

 

While you wait for a response from Corsair, my suggestion would be (if you can) to go to your nearest pc shop and purchase a pcie 3.0 ribbon. Thermaltake have one that has similar orientation as the original. You need the 200mm length one. Maybe remove the original so you can bring it and compare. I unfortunately do not have the original BIOS not even the original motherboard anymore. But I had issues with the original pcie ribbon and a new motherboard so I bought a new pcie ribbon and that fixed it. I believe you are right in changing to pcie gen 1. But I do think a new ribbon may allow you to run gen 2 so that you don't have to return back to a previous bios which can be risky.

Link to comment
Share on other sites

@EchoSierra

 

I do appreciate your reply. What you recommend makes total sense, and in the grand scheme of things, is probably the right step for me to take at this point. Logically, I'm never going to get the newer BIOS versions working on my system as-is, and there's no guarantee I'll get my hands on an older BIOS version either. But, as you suggested, I can change the game in my favor with a little DIY.

 

So, my next question, am I getting the correct riser cable? You mentioned ThermalTake, which I have a lot of positive experience with in the past on previous custom builds, so I looked up the part on Amazon and found this:

 

Thermaltake TT Gaming PCI-E x16 3.0 Black Extender Riser Cable 200mm AC-053-CN1OTN-C1

 

It's 200mm, but I'm not sure if this is the correct orientation. In my research on the matter, I found a post from a year ago on the r/Corsair sub-Reddit that goes into a little detail on the subject. If you look at the Imgur link in the third comment, I'm wondering if this is what I'll need to do in order to make it work? (I've attached those images for convenience/posterity.)

 

Thanks!

1Z7MaAa.jpeg.bd4977146be4f3b711b83f270b7fbfe5.jpeg

uDNjfVJ.jpeg.6eb47c8fed7ba0212555a10e2c182d34.jpeg

Edited by willfull
Link to comment
Share on other sites

That is the exact same ribbon that I bought. And funnily enough that is the same reddit thread I came across when trying to solve my issue. The original ribbon is 200mm also. So the ThermalTake one works perfect.

 

Be mindful though that the mounting holes on the new ribbon will not line up with the posts on the case like the original ribbon. So when you install it just connect it to the graphics card first and then mount the graphics card as per normal. This will not be an issue. I am running mine without the screws on the ribbon. Additionally, you may need to remove the display port junction just to have more space to work but then you can put it back.

 

When you remove the original ribbon, you can see how it was folded so you can just replicate that on the new ribbon. That is what I did and it will be easier than going by the photos on reddit. Also, to re-assure you, by design the new ribbon can be folded completely in the same way the original was.

 

Let us know how you go and feel free to ask more questions.

Edited by EchoSierra
Link to comment
Share on other sites

 Share

×
×
  • Create New...