Jump to content
Corsair Community

Recommended Posts

  • 1 month later...
This isn't uncommon with the Platinum coolers. I would suggest that you leave it in Balanced or Extreme. Quiet not only isn't quiet, it also negatively impacts your temperatures. The difference between Balanced and Extreme on temps in negligible.
Link to comment
Share on other sites

So it isn't normal then ?

 

It's not uncommon ... which means that it's pretty usual.

Seriously - set it to Balanced. You don't lose anything (doesn't impact lifetime), it's quieter AND you won't take a few degrees hit on the cooling.

Link to comment
Share on other sites

  • 2 weeks later...

Hmm.. I am also experiencing some noise issues with my H100i RGB Platinum cooler. Started about a few months ago, but frankly I didn't want to deal with it so i just let it ride. I have had it for about 8 months in this new build and over the past few weeks it seems to have progressively worsened. I just gave the "Balanced" setting a try, also shut the system down and then turned it back on. Given I just changed a few things, I'll let it play out for a a day or so before taking another look at possibly sending it back if the noise gets worse.

 

I remember having a similar issue with my H80 back in the day and it was a faulty pump. However, based on some discussions I saw here on the forum, I'll let it play out for a few days.

Link to comment
Share on other sites

  • 3 weeks later...
This isn't uncommon with the Platinum coolers. I would suggest that you leave it in Balanced or Extreme. Quiet not only isn't quiet, it also negatively impacts your temperatures. The difference between Balanced and Extreme on temps in negligible.

 

OK. I gave it a go to set to BALANCED. It did get significantly quieter.. and now it has dropped my cooling by over 1.5 degrees C. Interesting. :!:

Link to comment
Share on other sites

  • 3 weeks later...
OK. I gave it a go to set to BALANCED. It did get significantly quieter.. and now it has dropped my cooling by over 1.5 degrees C. Interesting. :!:

 

Well, it's become noisy, once again, even in balanced. I can try and go to Extreme to see if it addresses the issue. I'm really not a fan of having this thing making buzzing noises. Very irritating. :(:

Link to comment
Share on other sites

Well, it's become noisy, once again, even in balanced. I can try and go to Extreme to see if it addresses the issue. I'm really not a fan of having this thing making buzzing noises. Very irritating. :(:

 

OK, Well... it looks like my iCUE settings for Rainbow lighting are just staying RED. I'm opening a ticket. Thanks for listening. :)

Link to comment
Share on other sites

Hi, I've got similar problem with the noise. In my case its 2 loud in general no matter what preset I use and obviously as I'm concerned about noise I keep it on quiet which is still loud. On top of that when I put it on balanced mode you can hear crackling noise coming from the pump that does not happen on Extreme mode but that mode I never touch as its so loud. My fans on IDLE are set on 700rpms up to 40C and my IDLE temps on stock 3700X ambient 25C don't go over 35-36C but its 2 noisy even on the quiet preset. Not sure what to do wheter to send it back, any ideas?
Link to comment
Share on other sites

  • 8 months later...
Hi, I've got similar problem with the noise. In my case its 2 loud in general no matter what preset I use and obviously as I'm concerned about noise I keep it on quiet which is still loud. On top of that when I put it on balanced mode you can hear crackling noise coming from the pump that does not happen on Extreme mode but that mode I never touch as its so loud. My fans on IDLE are set on 700rpms up to 40C and my IDLE temps on stock 3700X ambient 25C don't go over 35-36C but its 2 noisy even on the quiet preset. Not sure what to do wheter to send it back, any ideas?

 

I dont want to resurrect an old thread but i recently got this cooler and im having this issue

 

Luckily on Quiet, i cant hear it to much ( i hear it ) but my case blocks most of the noise, but as soon as i go balanced, its just odd and hard to explain but it sounds like the motor is gargling , not the water.

 

I dont get it, whether its bubbles or the pump itself in the CPU block, its hard to tell.

 

On extreme, its to loud generally but it just sounds like a high rpm fan

Link to comment
Share on other sites

  • 1 month later...

I have same problem straight out of the box the Pump is making a hell of racket.

 

Quiet mode is loud, Balanced is Louder and Extreme is unbearable I can hear it in the next room.

 

Any one had any luck solving this issue as I'm still waiting for RMA on Corsair Power supply submitted over a month and a half ago, so another solution to this would be much appreciated.

Link to comment
Share on other sites

  • 1 month later...
mine too!! using about a month have rattling sound when i boot up my PC. how can the quality so bad. previously i use cheap brand like cooler master 6yrs without weird sound and issues...corsair is premium brand im very disappointed. and RMA is not fun at all
Link to comment
Share on other sites

 Share

×
×
  • Create New...