The Corsair User Forums  

Go Back   The Corsair User Forums > Corsair Product Discussion > Corsair Link

Reply
 
Thread Tools Search this Thread Rate Thread Display Modes
  #1  
Old 07-02-2016, 08:46 AM
Speed_Deamon's Avatar
Speed_Deamon Speed_Deamon is offline
Registered User
Speed_Deamon's PC Specs
 
Join Date: Jul 2016
Posts: 3
POST ID # = 860659
Speed_Deamon Reputation: 10
Angry Corsair Link: The Longest Running Joke In PC History!

A week ago I replaced my 4 year old H60i (which had lost some coolant to evaporation over time) with a new H80i V2. It's a terrific piece of hardware!

Unfortunately, the software causes my system to reboot randomly and consistently, every 6-8 hours. Like some invisible finger pressing the reset button!

After days of tearing my hair out trying to figure out the problem, I finally killed the c-link task and whadaya know?! No more reboots! Now I come to find that this is very common and has been going on for YEARS!

I had to register here and share my disgust at the lack of attention Corsair pays to major software bugs! I'll be using ASUS AI Suite to control the pump and fans and when I need my next water cooling solution, it won't be a Corsair!
Reply With Quote


1 members found this post helpful.
  #2  
Old 07-02-2016, 08:57 AM
red-ray red-ray is offline
Banned
red-ray's PC Specs
 
Join Date: May 2014
Location: England (GMT+1)
Posts: 7,152
POST ID # = 860660
red-ray Reputation: 81
Arrow ASUS AI Suite fails to use named mutexes

Quote:
Originally Posted by Speed_Deamon View Post
I'll be using ASUS AI Suite to control the pump
AFAIK ASUS AI Suite can't control the H80iV2 pump speed.

If you have ASUS AI Suite active you should not use any other sensor monitoring programs active as it is poorly engineered an fails to use the Global\Access_ISABUS.HTP.Method + Global\Access_SMBUS.HTP.Method + Global\Access_EC + etc. named mutexes to interlock access to the sensors. If you were doing this it could be the root cause of the system reboots.

That said I agree that Corsair Link is not of an acceptable quality.

Last edited by red-ray; 07-02-2016 at 09:00 AM.
Reply With Quote


  #3  
Old 07-02-2016, 05:34 PM
Speed_Deamon's Avatar
Speed_Deamon Speed_Deamon is offline
Registered User
Speed_Deamon's PC Specs
 
Join Date: Jul 2016
Posts: 3
POST ID # = 860712
Speed_Deamon Reputation: 10
Unhappy

Quote:
Originally Posted by red-ray View Post

AFAIK ASUS AI Suite can't control the H80iV2 pump speed.
Correct. What I meant to say was, "...to control the pump's fans."

Quote:
If you have ASUS AI Suite active you should not use any other sensor monitoring programs active. If you were doing this it could be the root cause of the system reboots.
After I discovered the cause was C-Link, I thought maybe there might have been the conflict you suggest, so I killed AI Suite and ran C-Link. 3 hours later, the invisible finger pushed the reset button.

Quote:
That said I agree that Corsair Link is not of an acceptable quality.
Mmm Hmm... And whose is the "poorly engineered" one really, then?
Reply With Quote


  #4  
Old 07-03-2016, 03:32 AM
red-ray red-ray is offline
Banned
red-ray's PC Specs
 
Join Date: May 2014
Location: England (GMT+1)
Posts: 7,152
POST ID # = 860749
red-ray Reputation: 81
Default

Quote:
Originally Posted by Speed_Deamon View Post
Mmm Hmm... And whose is the "poorly engineered" one really, then?
Both are poorly engineered, but for different reasons.

As AI Suite fails to use locks I can't safely use it so don't. This means that I can't sensibly comment on it's overall quality.

CL4 uses locks, but using a binary semaphore rather than a mutex is also poor engineering, see http://forum.corsair.com/forums/showthread.php?p=854006.

Given the number of issues I have reported in CL4 then the implementation and testing quality is not to an acceptable standard. I suspect many of the issues stem from a poor design.
Reply With Quote


  #5  
Old 07-03-2016, 03:39 AM
Speed_Deamon's Avatar
Speed_Deamon Speed_Deamon is offline
Registered User
Speed_Deamon's PC Specs
 
Join Date: Jul 2016
Posts: 3
POST ID # = 860752
Speed_Deamon Reputation: 10
Unhappy

And we come full circle. Back where I started in the OP.

:
Reply With Quote


Reply

Tags
bugs, corsair link, h80i, random reboots, water cooling

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -4. The time now is 07:55 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.