The Corsair User Forums

The Corsair User Forums (https://forum.corsair.com/forums/index.php)
-   Keyboards and Mice (https://forum.corsair.com/forums/forumdisplay.php?f=214)
-   -   Corsair K55 Numlock/Capslock issues? (https://forum.corsair.com/forums/showthread.php?t=175775)

Xariez 03-15-2018 12:50 PM

Corsair K55 Numlock/Capslock issues?
 
Heyyo,

I've really wanted a new keyboard for quite some time, and having RGB is a near-to must for me when it comes to computer accessories nowadays. Seeing how within my budget the K55 was as well, it was the perfect buy!

The keyboard has been working far beyond my expectations, until last night. All the LED's at the topright stopped working, though the functions themselves worked (CAPSLOCK and NUMLOCK, specifically).

I tried installing CUE and clicking around on mostly everything with no progress, leading me to uninstalling it as I saw it as unneeded software (but, is there a way to fix the issue using that software, i'll be glad to install it again).

On a good note, reconnecting the keyboard seems to have fixed the LED's, but on a bad note, this is not issues I want with a new product, about a day into use. I've also had to do this twice so far.

Should I bite the bullet and plug in my good old Logitech G110 and take this back to the shop first thing tomorrow, or are we rather looking at a firmware/software issue? I've seen people have similar problems, but do we yet have a "waterproof" fix or are we still lost on that?

For what it's worth, it seems to happen when I use fullscreen applications, or at the very least, I've seen it happen whenever I sit playing Watch Dogs. But I guess it may, or may not be a coincidence.

I've very recently updated my Bios and Chipset drivers for my motherboard (ASUS Z87-K), ensured that I've got the latest windows updates, and "force reinstalled" the generic keyboard drivers via Windows own device manager (following this guide).

Thanks a lot in advance!

EDIT 1: I NOW HAVE THE CAUSE OF THE ISSUE! (Though not the solution). When I unplug any other USB device, then plug it back in (for example, my headset charger), the Capslock and Numlock LED's freeze. Nice having the issue pinpointed, now for a solution. Anyone?

datsyuk 03-18-2018 02:16 PM

I'm having the same issue as you. I think aside from the way you found them to freeze there are other ways. Any dynamic lighting profile freezes mine every few minutes. Sometimes I don't even need to use any of the lock keys, go to use caps lock and they are already frozen. To get them working again I have to reset the board (BIOS mode back to normal polling rate switch).

Sit there and just spam the 3 keys they'll probably freeze instantly or within 10-15 seconds or so if you are looking to just test if they'll freeze or not.

I posted about this the other day: http://forum.corsair.com/v3/showthread.php?t=175626

I have Z370 and the K70, so I really don't know what this issue is tied to because it does not happen on my old PC (Z68 Gigabyte board).

Other threads on this issue:

http://forum.corsair.com/v3/showthread.php?t=135977 (from 2015 lol..)
http://forum.corsair.com/v3/showthread.php?t=134647 (2014 same issue)
https://www.reddit.com/r/Corsair/com..._lights_stuck/
http://forum.corsair.com/v3/showthread.php?t=132322
http://forum.corsair.com/v3/showthread.php?t=164783 (more recent 2017 thread)

It's either they are entirely clueless what causes it or don't care lol

Corsair Nick 03-19-2018 10:40 PM

Just responded to your original thread. We have been looking into this issue. Some resolutions do take time as it may not be as easily reproduced on our end.

http://forum.corsair.com/v3/showthread.php?t=175626


All times are GMT -4. The time now is 05:31 PM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2020, vBulletin Solutions, Inc.