Jump to content
Corsair Community

Search the Community

Showing results for tags 'capslock'.

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Forums

  • CORSAIR COMMS DEPARTMENT
    • Community Rules & Announcements
    • Live Event Announcements
    • New Product Releases
  • COMMUNITY DISCUSSIONS
    • Non-CORSAIR Tech, Benchmarks, and Overclocking
    • Games & Gaming
    • Battlestation and Build Showcase
  • TECHNICAL SUPPORT & CUSTOMER SERVICE
    • English Support
  • PRODUCT DISCUSSIONS
    • CORSAIR Software
    • Build Hardware
    • Gaming Peripherals
    • Audio Devices
    • Battlestation Hardware: Ambient Lighting, Furniture, etc.
    • CORSAIR Pre-Built Systems
    • CORSAIR Technologies Q&A
  • Alternative Languages
    • Deutscher Support (German Support)
    • French Support
    • Spanish Support
  • LEGACY TOPICS
    • Corsair Enthusiasts Section
    • Corsair Product Discussion
    • Alternate Language Support
    • Customer Service

Find results in...

Find results that contain...


Date Created

  • Start

    End


Last Updated

  • Start

    End


Filter by number of...

Joined

  • Start

    End


Group


About Me


Location


Interests


Occupation


Optical Drive # 1


Homepage


ICQ


AIM


Yahoo


MSN


Skype

Found 2 results

  1. Heyyo, I've really wanted a new keyboard for quite some time, and having RGB is a near-to must for me when it comes to computer accessories nowadays. Seeing how within my budget the K55 was as well, it was the perfect buy! The keyboard has been working far beyond my expectations, until last night. All the LED's at the topright stopped working, though the functions themselves worked (CAPSLOCK and NUMLOCK, specifically). I tried installing CUE and clicking around on mostly everything with no progress, leading me to uninstalling it as I saw it as unneeded software (but, is there a way to fix the issue using that software, i'll be glad to install it again). On a good note, reconnecting the keyboard seems to have fixed the LED's, but on a bad note, this is not issues I want with a new product, about a day into use. I've also had to do this twice so far. Should I bite the bullet and plug in my good old Logitech G110 and take this back to the shop first thing tomorrow, or are we rather looking at a firmware/software issue? I've seen people have similar problems, but do we yet have a "waterproof" fix or are we still lost on that? For what it's worth, it seems to happen when I use fullscreen applications, or at the very least, I've seen it happen whenever I sit playing Watch Dogs. But I guess it may, or may not be a coincidence. I've very recently updated my Bios and Chipset drivers for my motherboard (ASUS Z87-K), ensured that I've got the latest windows updates, and "force reinstalled" the generic keyboard drivers via Windows own device manager (following this guide). Thanks a lot in advance! EDIT 1: I NOW HAVE THE CAUSE OF THE ISSUE! (Though not the solution). When I unplug any other USB device, then plug it back in (for example, my headset charger), the Capslock and Numlock LED's freeze. Nice having the issue pinpointed, now for a solution. Anyone?
  2. I got a k55 recently, and after using it for the past couple weeks I have noticed that the status lights for the Caps lock and Num lock do not work. The keys themselves seem to work as they do perform the intended function, just the light showing if they are on/off do not. The macro light and the on for the win key lock both toggle correctly, just the Caps and Num lock do not. After looking through the forums this seems to be a common issue I guess.
×
×
  • Create New...