Jump to content
Corsair Community

Corsair Virtuoso stops working on windows 11

Recommended Posts

Hi Everyone,

I'm experiencing an issue with the Corsair Virtuoso wireless connection. I can use them for about a minute without any problems, but after that period of time, the sound starts to crackle when I receive incoming voice in apps such as Discord, Microsoft Teams, etc. Following some wired noises (resembling old internet connection tones), I lose all incoming audio and need to either restart the device or switch to a USB connection.

I've used them with different devices (MacBook and various PCs), but this error only occurs on mya main PC and specifically when I'm receiving voice sounds on the wireless connection. I can use them without issues with instrumental music or when connected via USB.

I've already reinstalled the operating system (Windows 11), but the problem persists. I'm out of ideas regarding what might be causing this issue.

Link to comment
Share on other sites

Experiencing the same issue since upgrading my PC
Currently running Windows 11, AMD 7800X3D, MSI B650 Edge Wifi motherboard. Seems to only occur when I have Discord open (and maybe a game)
I've watched entire movies on Netflix and no issues

Previous build was an Intel 4th gen i7 on Windows 10. Using the older iCue software

So far I've
- Set Power Options to High Performance. Also went to advanced and disabled USB selective suspend settings to Disabled
- Tried between iCue 4 and 5 but didn't seem like there was a difference. Maybe completely removing all of iCue and all drivers might fix it?
- In Windows Sound settings, I've changed for the headset, Advanced > Default Format, to 8 channel, 24 bit, 44100 Hz
- Removed all audio drivers via Device Manager. Re-installed iCue and installed the motherboard audio drivers from MSI
- Tested disabling the wireless card for my motherboard via the BIOS (in case there was interference)
- Used both the front and back USB ports of my PC. Also a USB extender which goes away from the computer

The issues I experience are either what you mentioned, or crackling sounds from all applications then eventually going back to normal

Edited by Xerotype
Link to comment
Share on other sites

After uninstalling all of iCue and restarting, it seems like the headset audio just straight up cuts out after a bit, but my microphone is still transmitting.

EDIT: nevermind, it also does the distorted audio as well

Edited by Xerotype
Link to comment
Share on other sites

  • 2 weeks later...

Found the issues I was having with my headset were to do with Lian Li's Connect-3 software

Disabling it stopped the interference issues. Updating the Lian Li software also seems to have worked.
So good chance its a third party program impacting it

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...