Jump to content
Corsair Community

Multiple failed modules DDR5 Vengeance 5600MT s

Go to solution Solved by Al Del Degan,

Recommended Posts

I recently purchased all the new parts to build a computer and I ordered FOUR 32GB Corsair Vengeance 5600MT/s DDR5 modules. After not being able to install Windows, I had a tech friend come over with all his diagnostic software and we found out that at least one of the memory modules was failing. Since they come in packs of two, I sent the set back and the new replacement set should arrive tomorrow. In the mean time, I was able to install windows on the computer with the remaining TWO 32GB modules installed. 

I should mention that I used to be a service tech and I have built hundreds of computers, so I wasn't careless or rough and I did observe the standard anti-static precautions.

Today after installing a bunch of my applications, it started blue-screening and saying it was having a memory hardware issue. The problem persisted after many reboots and worsened to the point where I wasn't able to successfully boot Windows anymore. I removed ONE of the 32GB modules and now the machine only has one module left. It boots and seem to be running fine for the past hour or two. 

I have the iCUE software installed and according to the sensors and graphs, everything is operating correctly and within tolerances for temperature and voltage. 

I find it hard to believe that out of two packages of modules I had two defects. I am hoping when the other two modules arrive tomorrow they will work fine, but I am wondering if there is something else that I should be aware of? Does anyone have any thoughts? 

I have a ASUS PRIME X670E-PRO WIFI motherboard with an AMD Ryzen 7 7700 processor and a Geforce RTX 3060 Ti OC edition graphics card.

Thank you for any information you can provide.



Link to comment
Share on other sites

It could be caused by the fact that you mix two kits of memory. That is never guaranteed to work. In fact it is rare that it does at XMP/EXPO timings without manually tweaking everything.

What happens if you only run one kit, on slots A2 and B2? this should definitely work.

Also make sure the motherboard is running the latest BIOS. that solves a great deal of memory related problems.


Link to comment
Share on other sites

Thank you for your response.

What do you mean by "mix two kits"?  Every one of the four modules is identical, I am not mixing anything. I am currently running two modules, one in A2 and one in B2 (according to the MB manual) and they are working fine, but the other two modules don't work at all, no matter if I put them in one at a time, both together, or all four.  

When you say "kits" I assume you mean two modules that came in the same box. Each of the two boxes only had one module that actually worked. The other one appears to defective. Right now I have the only working module from each box in the machine. 

Hopefully I am being clear, this is very frustrating to try and explain.

MB is at the latest non-beta BIOS. 


Link to comment
Share on other sites

  • 2 weeks later...
  • Solution

Having nothing but problems with the Corsair memory modules, I sent them all back and purchased another brand.

All four of the new modules I ordered from the other company installed without any problems the first time. 

Link to comment
Share on other sites

yea i meant mixing 4 sticks not sold as a matched quartet.

even with the same PN you're never sure to get the exact same chips or timings, even if the primary timings may be identical.

Glad it worked out in the end. I guess other companies have stricter rules regarding SKU performances.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...