Jump to content
Corsair Community

Unable to start iCUE properly, even after clean reinstall (Error code : 0xc0000409)

Recommended Posts

Hello there,

I'm working in IT. Today my iCUE 4.31.168 stopped working after I woke up my PC from extended standby. Here are all the fixes I tried :

  • uninstall + reboot + reinstall 4.31.168 + reboot
  • uninstall + clean AppData (local and roaming) + reboot + reinstall 4.31.168 + reboot
  • uninstall + clean AppData (local and roaming) + clean Windows register + reboot + reinstall 4.31.168 + reboot (as explained here)
  • uninstall + clean AppData (local and roaming) + clean Windows register + reboot + reinstall 4.30.162 + reboot (as explained here)

I also disabled auto start but nothing is working. It opens as "not responding" and after a few minutes just closes/crashes :


Any idea ? I searched for logs location but didn't find much, I just found a crash event in Windows Event viewer (translated from french with DeepL) :


Name of the failed application iCUE.exe, version:, timestamp: 0x636284f2
Name of the failed module: Qt5Core.dll, version:, timestamp: 0x5fa4dd3b
Exception code: 0xc0000409
Error offset: 0x00000000000204e8
ID of the failed process: 0x0x8BC
Start time of the failed application: 0x0x1D90D5B0FC7D864
Path of the failed application: C:\Program Files\CorsairCORSAIR iCUE 4 Software\iCUE.exe
Path to failed module: C:\Program Files\CorsairCORSAIR iCUE 4 Software\Qt5Core.dll
Report ID: 0093b981-3e9e-4c80-91f5-cc0c33f4ab9b
Full name of the failed package: 
Application ID related to the failed package: 


Link to comment
Share on other sites

Well, I found out that my Asus ROGLiveService.exe doesn't work either... And that Asus.com website is down which causes every Asus application (e.g. Armoury Crate) to stop working. Maybe it's my problem's root cause ? Corsair iCUE software should not crash if Asus components are not available though...

Edited by tigerblue77
Link to comment
Share on other sites

  • 2 months later...

Was there ever a fix to this? I'm having the same exact issue on the latest version 4.33.138. iCUE opens then freezes up and shows not responding. None of my preset RGB is working and my DPI on my mouse is always on default.

This is a very annoying issue and all of the fixes have not worked (including all the steps tigerblue did above AND the corsair recommended steps). I even did a system restore to before the issue happened. It worked, then on next reboot the problem was back.

Also for reference, everything was working fine, I shut down my PC, went to bed, and awoke to this issue.

Link to comment
Share on other sites

I also looked in the event viewer and see

The program iCUE.exe version 4.33.138 stopped interacting with Windows and was closed. To see if more information about the problem is available, check the problem history in the Security and Maintenance control panel.
 Process ID: 1dc0
 Start Time: 01d9505ead04b88b
 Termination Time: 60000
 Application Path: C:\Program Files\Corsair\CORSAIR iCUE 4 Software\iCUE.exe
 Report Id: b8ad402f-4723-4067-8e47-bacf1459f78f
 Faulting package full name:
 Faulting package-relative application ID:
 Hang type: Unknown

I am on the latest Windows Update.


Link to comment
Share on other sites

  • 1 month later...

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...