Jump to content
Corsair Community

AX1200i PSU Suddenly doesn't work, RED LED on the self test

Recommended Posts

Hello Corsair Team,

My gaming rig has been working fine since I built it in 2021, and the las70 t time it powered on was Aug 23, 2022.

Anyway, was playing Eurotruck Simulator 2 on this rig last tuesday and was working fine and shut down the computer like always. There was NO brownouts/sags and unit is also connected to an APC surge suppressor.

When I turned it back on last saturday (Aug. 27.) It was not turning on.

Then I disconnected all the cables and just powered on the AX1200i and pressed the self test button - that's the time when I saw the LED turn RED.

disconnected the power supply cable, waited 15 minutes and tried it again, still the same thing - Self test LED is RED.


I already have a case number: 2005511442, Not sure what else I can do at this point.



Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...