Jump to content
Corsair Community

Adapter USB of the HS60 PRO suddenly stopped working, but when I connect it to the 3.5mm port, it works, what is the solution?


Recommended Posts

 Hello 👋 

I have a Corsair HS60 PRO headset Suddenly, without warning, I was playing Valorant. Suddenly the speaker sound disconnects for a minute or two and then suddenly comes back, but the sound is weak and there are problems and strange sounds. I checked the ICUE program, the program did not show me the headset, I deleted the program and reinstalled it, but the same problem and within the Windows settings writes to me that the headset is not known As HS60 pro, I decided to remove the shunt and use a 3.5mm wire. It works without problems, but when connected via USB, the reputation does not appear in the program and does not work 

Note that I sent to support via e-mail and no one responded to me. Please support as soon as possible. Thank you 

 

٢٠٢٢٠٦٠٦_١٤٣٨٥٠.png

Link to comment
Share on other sites

  • Corsair Employees

Hi @Joud Kayale,

please create a ticket via https://help.corsair.com/hc/en-us/requests/new and send us a photo of the label on the inner side of the headband (or a photo of the label on the packaging) as well as your address and phone number. We can then check for sending a replacement dongle.

- LandLubber

  • Like 1
Link to comment
Share on other sites

  • Corsair Employees

@Joud Kayale Thank you for creating a ticket. It has already been assigned to an agent and you should receive a response shortly.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...