Jump to content
Corsair Community

Equalizer not working in Icue

Recommended Posts

  • 2 weeks later...
  • 1 month later...
  • 1 month later...

I recently faced the same issue.... Im running Win 10.

My fix for that was to download the driver file manualy because windows just applied the standard wich was obviously not working.....

version: (19 Dec 2022)
*.inf-file: corsairgamingaudio.inf
after i got that i just went to device manager selected the corsair device i got (for me: ST100 Headset Output) and updated it to that particular version...
dont ask me where i got it from i cant remember... but it was not corsair site.... whatsoever glad it works now
Edited by Vaqtastiq
Link to comment
Share on other sites

  • 3 weeks later...

I have been having the same issue on standard windows 10 after an update. I am Using a Corsair Viruoso SE.

I am NOT running any insider build. However, I did manage to fix it....

Funny enough its the same way to fix the swapped Left and Right Audio issue... Just Plug in your Headset to your PC via USB, then switch it to USB/Off mode, change audio device on the windows start bar to the Headset again. Then swap EQ presets to verify its working. If it is, then swap it back to wireless mode and swap EQ once again to verify....

This is what worked for me, and I recommend at least trying this too before wiping iCue

Link to comment
Share on other sites

  • 2 months later...
On 4/5/2022 at 12:58 AM, Corsair Blade said:

Hi Mechan1c,

We first recommend performing a clean install of iCUE. Please follow the steps below:

Open your computer's Control Panel.
Open the Programs and Features options.
Select Corsair Utility Engine in the list, and then select Uninstall.
Press Window Key + R to open the Run command.
Type %appdata% and press Enter.
Delete any Corsair folders in the window that pops up.
Return to the Run window and type %localappdata%.
Delete any Corsair folders in the window that pops up.
Open File Explorer and navigate to C:\Program Files (x86)\ for iCUE 3, or C:\Program Files\ for iCUE 4.
Delete any Corsair folders in that folder.
Type Regedit in the Run window and then click OK.
Go to HKEY_CURRENT_USER\Software\ and delete the Corsair folder.
Go to HKEY_LOCAL_MACHINE\SOFTWARE\ and delete the Corsair folder.
Restart your computer.
Download a new installer file for iCUE from Corsair.com and reinstall.

If you need assistance with these steps, please reach out to our support team.

That works for me in Win 10 - Corsair Virtuoso SE.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...