Jump to content
Corsair Community

Equalizer not working in Icue


Recommended Posts

The equaliser in ICUE doesnt effect the sound in any way. Its just a flat sound. If i manually adjust the EQ sliders in corsair ICUE nothing happens to the bass, mid and treble tones.

I have tried various versions of the icue software. My heaphones are Virtuoso RGB. I have raised a ticket for this problem 4 days ago and not heard anything back. Quite frustrating!

System Spec:

Windows 11

Gigabyte z690 Gaming DDR4

Intel 12700kf

32gb Corsair ram

RTX 3070

Link to comment
Share on other sites

  • Corsair Employees

Hi Mechan1c,

We first recommend performing a clean install of iCUE. Please follow the steps below:


Open your computer's Control Panel.
Open the Programs and Features options.
Select Corsair Utility Engine in the list, and then select Uninstall.
Press Window Key + R to open the Run command.
Type %appdata% and press Enter.
Delete any Corsair folders in the window that pops up.
Return to the Run window and type %localappdata%.
Delete any Corsair folders in the window that pops up.
Open File Explorer and navigate to C:\Program Files (x86)\ for iCUE 3, or C:\Program Files\ for iCUE 4.
Delete any Corsair folders in that folder.
Type Regedit in the Run window and then click OK.
Go to HKEY_CURRENT_USER\Software\ and delete the Corsair folder.
Go to HKEY_LOCAL_MACHINE\SOFTWARE\ and delete the Corsair folder.
Restart your computer.
Download a new installer file for iCUE from Corsair.com and reinstall.

If you need assistance with these steps, please reach out to our support team.

  • Like 1
Link to comment
Share on other sites

Hi,

Thanks for your response. I tried doing that before i posted the problem. It still doesnt work. I have raised a ticket with technical support.

Regards

Link to comment
Share on other sites

I've got the Virtuoso SE, on firmware 5.3.70 and dongle 5.7.115. Just updated to 4.22.203 on Windows 11 Insider Preview 22593.1 and same, equalizer won't work anymore. I did a clean install of Icue, a clean install of the drivers, tried eq-ing, tried 7.1 and nada. I don't know what is going on. I think that something broke with the update I just did to Icue because previous to doing it the Equalizer window worked perfectly. 

  • Like 1
Link to comment
Share on other sites

On 4/12/2022 at 4:05 AM, Anihilitus said:

I've got the Virtuoso SE, on firmware 5.3.70 and dongle 5.7.115. Just updated to 4.22.203 on Windows 11 Insider Preview 22593.1 and same, equalizer won't work anymore. I did a clean install of Icue, a clean install of the drivers, tried eq-ing, tried 7.1 and nada. I don't know what is going on. I think that something broke with the update I just did to Icue because previous to doing it the Equalizer window worked perfectly. 

Same problem and same windows version!

  • Like 2
Link to comment
Share on other sites

On 4/12/2022 at 8:05 AM, Anihilitus said:

I've got the Virtuoso SE, on firmware 5.3.70 and dongle 5.7.115. Just updated to 4.22.203 on Windows 11 Insider Preview 22593.1 and same, equalizer won't work anymore. I did a clean install of Icue, a clean install of the drivers, tried eq-ing, tried 7.1 and nada. I don't know what is going on. I think that something broke with the update I just did to Icue because previous to doing it the Equalizer window worked perfectly. 

I am still trying to sort the problem with corsair technical support. I am on the windows insider program too on windows 11. I wonder if that has something to do with it? I have tried everything technical support has suggested and everything else i can think of. Have you managed to sort the problem?

Link to comment
Share on other sites

13 hours ago, msbearbr said:

Same problem and same windows version!

I wonder if it has something to do with windows insider previews? I am on the same build as you and Anihilitus.I will ask technical support.

Link to comment
Share on other sites

So it is something about the update that broke with the insider preview? Weird that the previous Icue update hadnt .-. oh well, good to know at least

Link to comment
Share on other sites

  • 1 month later...

Hello there. 

I have the same problem but with Windows 10 and the Void Elite USB. Still trying to get it working, if someone have also the problem of win10.

 

Link to comment
Share on other sites

  • Corsair Employees
1 hour ago, Cyborck said:

Hello there. 

I have the same problem but with Windows 10 and the Void Elite USB. Still trying to get it working, if someone have also the problem of win10.

 

What troubleshooting steps have you already taken? 

Link to comment
Share on other sites

Posted (edited)

Same with me im using the Corsair void elite pro i just updated icue and then my equalizer stopped working ive been trying to fix it ever since (i just updated today btw restarted about 8 times)im also on windows 10

Edit: NVM i just fixed it i did it step by step then my audio back thank you!!!!

Edited by Jngmaow
Link to comment
Share on other sites

  • Corsair Employees
On 5/30/2022 at 2:09 PM, Jngmaow said:

Same with me im using the Corsair void elite pro i just updated icue and then my equalizer stopped working ive been trying to fix it ever since (i just updated today btw restarted about 8 times)im also on windows 10

Edit: NVM i just fixed it i did it step by step then my audio back thank you!!!!

Just to clarify / add context for anyone else who has the issue, what exactly did you do that fixed it in your specific case? The clean install? 

Link to comment
Share on other sites

  • 2 weeks later...

Following the clean install of icue made it work again for me.  

I've done a clean install and the past and the issue always came back shortly after, so I'll let you know if/when that happens.

Link to comment
Share on other sites

Having the same issue. I followed the uninstall directions, reinstalled and still nothing. I am on the Windows Insider program, release preview. It's not worth it to uninstall insider preview just for this, although it is a pain in the behind to not have the EQ working like it should be.

Link to comment
Share on other sites

  • 2 weeks later...

when i have no effects on my void i go to windows 11 sound settings and then the settings for the void, there i enable the slider for enhanced audio and then the equalizer and surround effects actually work.

Link to comment
Share on other sites

  • 1 month later...

I started to have this issue also.

EQ, Stereo, 7.1 etc.... nothing change the sound.

And in the Windows settings, all options that control the audio are off, like Spatial, enhance etc..

 

My iCue is updated (and this issue was happing in the previous version and after the update I did just now also.

Link to comment
Share on other sites

Just in case, I opened one ticket.... let's see if they will ignore my issue, or work together to find one solution.

Link to comment
Share on other sites

Same issue on Windows 11 (Insider...)

Link to comment
Share on other sites

  • 2 weeks later...

Figured mine out.

Try going into settings, go to System, then go into the sound tab scroll down to the advanced section then to all sound devices, find "headset earphone"(CORSAIR VIRTUOSO SE USB Gaming Headset), find Enhance audio and click it on.

Windows 11

Edited by Daytona125
added to
Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...