Jump to content
Corsair Community

RGB stuck on red unable to change any RGB


vender13
 Share

Recommended Posts

My K65 RGB Rapidifre has stopped syncing with my ICUE Rainbow six siege RGB profile and is currently stuck on red I can't even seem to change the color anymore like the RGB controls are broken even though it worked fine yesterday. I've tried reinstalling ICUE which didn't change anything. Unplugging the keyboard results in a short flash of my rainbow six siege profile before switching back to red again. After this I've tried using different usb ports with no success. I have attached the ICUE logs, there seems to be some error there but no clue what exactly. Even though the rest of my Corsair RGB ML120/140, H115I and Corsair veagance RGB Pro are working fine with the profile.

2020-12-17T17-20-56.log

Edited by vender13
Link to comment
Share on other sites

  • Corsair Employees

Hi vender13,

 

Try resetting your K65 RGB Rapidfire. To reset it:

 

  1. Unplug your keyboard.
  2. With the keyboard unplugged, hold down the ESC key.
  3. While holding down the ESC key, plug the keyboard back into your computer.
  4. After about 5 seconds, release the ESC key. You will see the keyboard lighting flash if the reset is successful.

Link to comment
Share on other sites

 Share

×
×
  • Create New...