Jump to content
Corsair Community

Corsair VOID PRO Wireless only works plugged in


Tisor
 Share

Recommended Posts

Hi,

 

I bought a Corsair Void Pro RGB 2 weeks ago. I've been amazing by them. Perfect audio quality, good battery duration, long distance wireless. Everything was perfect.

 

Suddenly, yesterday, after leaving them charging all night as always on the powered USB HUB I've got, I unplugged them from the USB and tried to turn them on. Nothing happens.

 

When I plug them in again, they turn on, but they act strange. I can't turn them off, I can turn the mic off. Apart from that, they are working OK, but they are not wireless anymore...

 

When I unplug them from the USB charging, they turn off and won't turn on again.

 

After 2 weeks of use, is normal that the battery has died? iCue shows now battery is 100% when usually it won't show more than 94%.

 

Things I've tried so far:

 

- Tested several charging modes (HUB USB, PC own ports, Phone USB Charger)

- They are not on bootloader mode. (On bold, as will be the first thing I'm gonna be told for sure)

- Tried a soft reset as stated here, but I can't do it as I cannot unplug them and turn them on.

- Tried a firmware update via iCue.

 

 

Is there any chance this a known issue and is fixable? I have already asked refund from Amazon and bought a new pair, but the new pair is arriving mid-may and I don't have another headset...

 

Best regards

Link to comment
Share on other sites

 Share

×
×
  • Create New...