Jump to content

Search the Community

Showing results for tags 'no charging'.

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Forums

  • CORSAIR COMMS DEPARTMENT
    • Community Rules & Announcements
    • Live Event Announcements
    • New Product Releases
  • COMMUNITY DISCUSSIONS
    • Non-CORSAIR Tech, Benchmarks, and Overclocking
    • Games & Gaming
    • Battlestation and Build Showcase
  • TECHNICAL SUPPORT & CUSTOMER SERVICE
    • iCUE Software Troubleshooting
    • Build Hardware Troubleshooting
    • Gaming Peripherals & Audio Troubleshooting
    • Furniture and Ambient Lighting Troubleshooting
    • CORSAIR Pre-Built Systems Troubleshooting
  • PRODUCT DISCUSSIONS
    • CORSAIR iCUE
    • Build Hardware
    • Gaming Peripherals
    • Audio Devices
    • Battlestation Hardware: Ambient Lighting, Furniture, etc.
    • CORSAIR Pre-Built Systems
    • CORSAIR Technologies Q&A
  • Alternative Languages
    • Deutscher Support (German Support)
    • French Support
    • Spanish Support
  • LEGACY TOPICS
    • Corsair Enthusiasts Section
    • Corsair Product Discussion
    • Alternate Language Support
    • Customer Service

Categories

  • System Build Inspiration
  • Memory
  • Cases
  • iCUE CONTROLLERS
  • Maximizing Performance
  • Peripherals
  • Storage
  • Liquid Cooling
  • Gaming Mice
  • News and Events
  • How-tos and DIY
  • USB Drives
  • Extreme OC Mods
  • Gaming Keyboards
  • Power Supply Units
  • Gaming Headsets
  • Uncategorized

Find results in...

Find results that contain...


Date Created

  • Start

    End


Last Updated

  • Start

    End


Filter by number of...

Joined

  • Start

    End


Group


About Me


Interests


Occupation


Optical Drive # 1


Homepage


ICQ


AIM


Yahoo


MSN


Skype

Found 2 results

  1. Hello. First of all I'm sorry for my english I'm not that good. I bought a new void elite and it was working until this morning. I played a game and turned off my computer but when ı oppend my computer ı couldn't opend my headset and when I tried to charge it there wasn't any light on charcing port light and my computer didn't saw my headset connected. I'm sure it has battery because It was almost full in the morning. It looks like dead no voice no light no any thing that ı can see. Please help me should I return it but I don't want to do because I want to use this headset.
  2. Hi, I bought a Corsair Void Pro RGB 2 weeks ago. I've been amazing by them. Perfect audio quality, good battery duration, long distance wireless. Everything was perfect. Suddenly, yesterday, after leaving them charging all night as always on the powered USB HUB I've got, I unplugged them from the USB and tried to turn them on. Nothing happens. When I plug them in again, they turn on, but they act strange. I can't turn them off, I can turn the mic off. Apart from that, they are working OK, but they are not wireless anymore... When I unplug them from the USB charging, they turn off and won't turn on again. After 2 weeks of use, is normal that the battery has died? iCue shows now battery is 100% when usually it won't show more than 94%. Things I've tried so far: - Tested several charging modes (HUB USB, PC own ports, Phone USB Charger) - They are not on bootloader mode. (On bold, as will be the first thing I'm gonna be told for sure) - Tried a soft reset as stated here, but I can't do it as I cannot unplug them and turn them on. - Tried a firmware update via iCue. Is there any chance this a known issue and is fixable? I have already asked refund from Amazon and bought a new pair, but the new pair is arriving mid-may and I don't have another headset... Best regards
×
×
  • Create New...