Jump to content
Corsair Community

Sometimes keyboard isn't detected in iCUE

Recommended Posts

Hi !

I've got an issue with my keyboard that has been going on for a while,

it's the LEDs, whenever I restart my PC (most of the times, not every time),

my keyboard doesn't get recognized by iCUE.


the issue it causes is, that the keyboard defaults to red and white LEDs and I don't have the 'CAPS LOCK' LED and I never know when it's active or not ><

I can still use the keyboard and everything works though.


I tried:

- Different USB ports (3.1, 3.0, rear and front. I don't have 2.0)

- Delaying iCUE on startup

- Closing and opening iCUE

- Force re-installing the keyboard's firmware


*Note on the USB ports, I tried about 3-4 ports, not every port*


Nothing changed it, but in order to detect the keyboard and the LEDs and everything, I have to manually disconnect the cable and reconnect it.


I also tried navigating through the BIOS (Gigabyte z390 m) and device manager to see if there's anything related to power that may affect anything, I didn't find anything interesting there.


My OS is Windows 10 Pro (latest version, formatted 2 months ago),

and every chipset driver + BIOS is updated, iCUE and the keyboard are updated as well.


Also another thing to note about iCUE,

I got a Commander Pro and a PSU, both are getting detected no problem.


Does anyone know how to approach it?

Thanks. !

Link to comment
Share on other sites

  • 1 year later...

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Create New...