Jump to content
Corsair Community

Keyboard suddenly stopped working


Recommended Posts

I have an issue with my corsair k70 gaming keyboard (non rgb with red switches).

It worked flawlessly since i bought it (15.07.2015 (dd.mm.yyyy)) but yesterday after unplugging it and taking my laptop to a friends place, it wouldn't turn on at all. No backlight or working keys. It's not even recognized as a standard keyboard by windows. Plugging it into other usb ports doesn't work either, although other devices work on those same ports. Trying another computer doesnt work eiter (again not recognized at all). There was no windows update since unplugging it. Restoring the pc to an earlier date didnt help either.

No physical damage (no spillage or damage from dropping it, etc)..i didn't move it since the last time it worked.

Setting the keyboard to BIOS-mode doesn't help (no led is blinking and the keys dont work either).

I'm guessing i don't have a warranty anymore either, since it's 2+ years old and i'm all out of ideas.


Thank you in advance for any help.

Link to comment
Share on other sites

  • Corsair Employees

Try performing a soft reset on the keyboard and see if that revives it:


1) Unplug the keyboard

2) Set the BIOS switch to the (1) position

3) Hold the ESC key and plug the USB with the keyboard logo into a USB 3.0 port

4) Release ESC after 5 secs


If this doesn't resolve the issue, you can contact our Technical Support staff, and they can provide you with what options are available to you.



Link to comment
Share on other sites



I also have a K70 non RGB that stopped working after I rebooted my PC!


I have tried the soft reset holding esc key... But this was not successful.


I raised a support ticket and got a reply to try the soft reset despite documenting on my ticket this had already been tried!


I would be greatfull if you could post a reply on how you got on with your support ticket?


Did support offer any info or software capable of "Hard" resetting the keyboard?





Link to comment
Share on other sites

Hello Andy,


unfortunately nothing worked.

The support send me a tool to reset the firmware, but since my pc cant detect the keyboard at all it didnt work.

There really isnt anything i can do anymore. As a last resort i opened my keyboard to see if i can see a broken resistor or chip, but no luck there. Although i didnt take it apart completely as to not break anything.

While at it i also measured if the its just a broken usb cabel, but that worked fine.

I concluded that its propably a burned chip and since i dont have the tools to desolder smds anymore i set it aside and came to terms with the idea of buying a new keyboard.

You could try to send it to a local repairshop, although its propably not worth the cost.





Link to comment
Share on other sites

The same thing just happened to my K70 non-RGB bought about the same time as maroda's. The USB pass-through still works so the USB cabling is OK, but the keyboard is completely dead, no lights, no response on either of two computers. It used to work fine on both computers. I contacted support but their only response was "So sorry, out of warranty". I'll try the firmware reset mentioned above, but it would have been nice if support had been a bit more, well, supportive. I did like the keyboard, but it's too expensive for only 2 years service. Given both keyboards were purchased around the same time leaves me wondering if Corsair had a bad production run.
Link to comment
Share on other sites

  • 9 months later...


This topic is now archived and is closed to further replies.

  • Create New...