Jump to content
Corsair Community

Wireless Corsair Void Microphone not working


Recommended Posts

This hasn't been an issue until today, but when I tried to talk to my friends on discord, my PTT wasn't working, so I tried reassigning the key and I still got no light, so I tried to turn voice activation on, but discord couldn't pick up any sound from my mic even when i blew hard against it. I checked to see if I had pressed the mute button on the side of the headphone but that didn't work either. I just tested in windows voice recorder to make sure it isn't a discord issue, but I got no sound there either, and also went into "Set up a microphone" and got no audio from that. I checked in devices to make sure it was on, and the only audio device on, and it was.


I'm not sure if it's a low battery thing but I often see a red light next to my microphone, I don't know if that actually indicates if it's on or off, but I don't have any red lights on it right now.

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...