Jump to content
Corsair Community

CUE 2 doesnt load! But CUE 1 works!


Agrivar2277
 Share

Recommended Posts

HI.

 

I just bought a Strafe RGB with the new silent MX switches and tried loading the CUE 2 sw. It installs but after that it doesnt open. I'm running windows 10 and my OS is autoupdated every day.

 

I tried v 2.6.7 - installs but doesnt load

then removed that and tried 2.5.66. - installs but doesnt load

desparate, i tried 2.4.66 - also installs but doesnt load.

 

Very desparate now, i downloaded CUE v 1.16.42 and guess what? IT WORKS!

it finally started and auto downloaded a firmware patch 2.05 for my KB.

 

Then thinking it could be a FW issue, i proceeded to uninstall CUE 1.16.42 and retried all 3 versions of CUE v2. All refuse to load. So i guess i'm stuck using 1.16.42.

 

Anyone remotely has any feedback? First time corsair user and i'm thinking i should have gone and bought a Razer..

Link to comment
Share on other sites

I replied earlier to your other thread in the CUE 2 open beta forum, don't post duplicate threads or you'll get duplicate answers and it becomes messy, Maybe something posted in one gets repeated in the other and so on, better keep everything in the same one :p:
Link to comment
Share on other sites

 Share

×
×
  • Create New...