The Corsair User Forums  

Go Back   The Corsair User Forums > Corsair Product Discussion > iCUE Software

Reply
 
Thread Tools Search this Thread Rate Thread Display Modes
  #1  
Old 06-09-2019, 05:33 AM
justinindian justinindian is offline
Justinindian
justinindian's PC Specs
 
Join Date: Jun 2019
Posts: 3
POST ID # = 1007425
justinindian Reputation: 10
Default Icue Software constantly disconnects peripherals then reconnects randomly

Ever since I downloaded the iCUE software, I've noticed that it causes this issue for me. All my peripherals disconnect for 5-10 seconds and then reconnect right after in 5-20 minute intervals. I really want to be able to use the macros and rgb on my k95. I've tried uninstalling, checking for updates, and resetting windows. Thanks.


PS. this is my first thread and I'm quite new to this forum
Reply With Quote
  #2  
Old 06-09-2019, 09:32 AM
DevBiker's Avatar
DevBiker DevBiker is offline
CORSAIR Beta Team
DevBiker's PC Specs
 
Join Date: Feb 2017
Location: Republic of Texas
Posts: 7,509
POST ID # = 1007441
DevBiker Reputation: 88
Default

Can you please be more specific ... which peripherals? Is it just the K95?
Do you have logs?
__________________
Please click "Edit System Specs" and fill out your system info.

This comment is provided "as-is", without warranty of any kind, express or implied, including, but not limited to, the sanity or mental fitness of the author. The author is not a Corsair employee, does not represent Corsair, and no comment should be construed as an official statement from Corsair.

Reply With Quote
  #3  
Old 06-10-2019, 10:35 AM
justinindian justinindian is offline
Justinindian
justinindian's PC Specs
 
Join Date: Jun 2019
Posts: 3
POST ID # = 1007526
justinindian Reputation: 10
Default

It disconnects all the peripherals. This includes my razer deathadder mouse, corsair st100, void pro RGB wired headphones, and a little phone charging cable.
Reply With Quote
  #4  
Old 06-10-2019, 11:52 AM
DevBiker's Avatar
DevBiker DevBiker is offline
CORSAIR Beta Team
DevBiker's PC Specs
 
Join Date: Feb 2017
Location: Republic of Texas
Posts: 7,509
POST ID # = 1007530
DevBiker Reputation: 88
Default

That's odd - why do you think that it's iCUE disconnecting the Razer mouse or the phone charging cable?
__________________
Please click "Edit System Specs" and fill out your system info.

This comment is provided "as-is", without warranty of any kind, express or implied, including, but not limited to, the sanity or mental fitness of the author. The author is not a Corsair employee, does not represent Corsair, and no comment should be construed as an official statement from Corsair.

Reply With Quote
  #5  
Old 06-17-2019, 01:20 AM
ashumann12 ashumann12 is offline
Registered User
ashumann12's PC Specs
 
Join Date: Aug 2017
Location: North Alabama
Posts: 2
POST ID # = 1008255
ashumann12 Reputation: 10
Default

I am having the exact same problem. iCue just stops working then restarts, effecting all connected Corsair products. Even when PC is pretty much idle.

iCue logs: https://drive.google.com/file/d/172i...ew?usp=sharing
Reply With Quote
  #6  
Old 06-19-2019, 06:05 PM
Dreadnaught503 Dreadnaught503 is offline
Registered User
Dreadnaught503's PC Specs
 
Join Date: Jun 2019
Posts: 14
POST ID # = 1008557
Dreadnaught503 Reputation: 10
Default

I am having the same issue where my Corsair Dark Core RGB SE will randomly disconnect itself then it never reconnects itself. This problem is very frustrating and i wish Corsair would fix it all ready.
Reply With Quote
  #7  
Old 06-20-2019, 12:18 PM
justinindian justinindian is offline
Justinindian
justinindian's PC Specs
 
Join Date: Jun 2019
Posts: 3
POST ID # = 1008656
justinindian Reputation: 10
Default Fix?

After updating iCUE to software version 3.17.94 the problem seems to have fixed itself.
Reply With Quote
Reply

Tags
icue problem, peripherals

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -4. The time now is 05:41 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.