Jump to content
Corsair Community

Force 3 GB Updating firmware from 1.3.3?


Recommended Posts

Hi there,


I've been having BSOD problems with my Corsair Force 3 60GB SSD since I installed it and recently realised that it was due to my firmware being rather out of date. I've managed to push it from 1.2 up to 1.3.3 using the Corsair Field Updater but am unsure where to go from there.


I've tried using the SSD Toolbox to update to the most recent firmware, but that fails (because my current firmware is still too low to use the Toolbox, I presume)


I've tried searching the forums for the next step but haven't had much luck. Any help would be appreciated!


Thanks guys!

Link to comment
Share on other sites

You need to use the manual 5.05 update files to update the FW as the SSD Toolbox does not support updating from 1.3.X to 5.XX.


Please note that we currently do not support upgrading old 1.3.x FW to 5.0x FW on Sandforce based drives. Users of 1.3.x firmwares will still need to update to 5.xx firmwares using the Sandforce based FW update process found in the SSD Firmware Update section.

Source: http://forum.corsair.com/v3/showthread.php?t=118314


FW 5.05: http://forum.corsair.com/forums/showthread.php?t=117994

Link to comment
Share on other sites

  • 11 months later...
  • 2 weeks later...

My current firmware version is 1.3.3


The SSD toolbox always fails when trying to update, found on other sites that this is a known issue when the firmware is below 5.

I've also tried with the "SSD Firmware Update Tool" where you manually have to select the firmware file.

For the firmware file I've used: "22788_fw.vic"


I have this disk connected to a Gigabyte motherboard P55-UD4 rev.1 with Bios version 9. (AHCI is enabled and SMART is disabled)

The operating systemd I'm using is Windows 7 Home Premium 64bit


During the classification test from Windows I noticed that the performance of this disk has drastically decreased. Even when I have 40 Gb of free disk space.

(Disk is in total 120 Gb)

That's why I would like to upgrade the firmware.


The disk's detailed specs are:

Model: Corsair Force 3 SSD

S/N: 12136503000013413127

FW Rev: 1.3.3

Signature: 142.142.227788

Capacity: 111.79 GB

Link to comment
Share on other sites

Double check and make sure the SSD is plugged into an Intel SATA port, not the Gigabyte SATA2 chip.

Intel® P55 Express Chipset:

6 x SATA 3Gb/s connectors (SATA2_0, SATA2_1, SATA2_2, SATA2_3, SATA2_4, SATA2_5) supporting up to 6 SATA 3Gb/s devices

Support for SATA RAID 0, RAID 1, RAID 5, and RAID 10



2 x SATA 3Gb/s connectors (GSATA2_0, GSATA2_1) supporting up to 2 SATA 3Gb/s devices


Have you tried the MSAHCI drivers instead of the Intel drivers?

Run a ATTO benchmark and post a screenshot.

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...