Jump to content
Corsair Community

TWIN3X2048-1333C9DHX in an Intel DP45SG board


TedM

Recommended Posts

Most of the following took place in an email exchange between RamGuy and me. I am putting it on the Forum because I thought others might find it informative and there are still some unanswered questions.

 

Salient parts of my system include: Intel DP45SG motherboard (with the latest BIOS and chipset driver revisions), Intel E8400 Dual Core, Windows XP Professional 32bit, SP2. I am not into overclocking, just want a good stable system.

 

I installed a set of Corsair TWIN3X2048-1333C9DHX for a total of 2 gigs of memory (DIMM 0, Chan, A&B). These were absolutely dead stable, and surprisingly fast considering the latency. The system automatically recognized them exactly as advertized - 1333MHz, 9-9-9-24, 1.5v. (I'll call these the "old" pair.) BTW, I chose these sticks because the DP45SG board will only support a maximum of 1333MHz.

 

I liked them so much, I bought another pair to max out the system at 4 gigs. These were labeled on the box as being identical - Corsair TWIN3X2048-1333C9DHX. (I'll call these the "new" pair.)

 

Troubles began immediately when I installed them (DIMM 1, Chan. A&B). Having all four on the board resulted in numerous POST failures, blue screens, and most intriguingly, the system often failed to recognize the LAN. As I run a cable modem, this meant no Internet!

 

Looking at the BIOS, I found that the system had automatically recognized the four stick combo as 1066MHz, 8-8-8-20. This seemed odd, so I took out all four sticks and inspected them.

 

What I saw was that, even though the box specifications were identical, the sticks were not. In small print on the old pair, it said "1.50v ver1.1" while on the new pair, it said "1.60v ver1.2".

 

I installed the new pair by themselves (DIMM 0, Chan. A&B). The system automatically recognized them as 1066MHz, 7-7-7-20. This in spite of the fact that the text on the sticks advertised them to be 1333MHz, 9-9-9-24, same as the old pair. This pair would boot normally (though POST took much longer than with the old pair), but I was amazed to find that with the new pair installed by themselves, the system once again would not recognize the LAN !!! I reset the new pair in the BIOS as 1333MHz, 9-9-9-24, and at 1.6v as the text on the sticks indicated. No change.

 

At this point I contacted RamGuy via email. I had signed up for this forum, but my membership had not been recognized yet, so I proceeded with email instead.

 

RamGuy made suggestions for the four stick combo - set BIOS manually, memory voltage to 1.8v, and add .2v to MCH (default is 1.1v, so this made it 1.3v). Unfortunately, it didn't work - same problems as before. I also reset them in the BIOS at both 8-8-8-20 and 9-9-9-24 and both 1066 and 1333. No change

 

RamGuy also advised me to test the memory with memtest. I have UBCD v4.1.1, so threw all the memory tests at it. Old sticks installed alone tested perfect after six full passes of MemTest and 13 full passes of MemTest+. New sticks likewise. I also tested them as mis-matched pairs, one old, one new (which were recognized as 1066MHz, 8-8-8-20). These were also perfect. However, all four sticks together failed, showing bad ram at address 0x5834f774. In all these tests, I reset the BIOS in all the various configurations above, mentioned but came up with the same results.

 

Curioser and curioser!

 

Today, I did a search of Intel support manuals, and found that the latest revision of the DP45SG tech manual (Oct., 2008) states the board will ONLY support: "DDR3 1066 DIMMs with SPD timings of only 7-7-7 or 8-8-8 (tCL-tRCD-tRP) OR DDR3 1333 DIMMs with SPD timings of only 9-9-9 or 10-10-10 (tCL-tRCD-tRP)" (among other settings - this is quoted directly from the Intel manual).

 

Thus, the answer MAY be that the combination of the old set (1333MHz, 9-9-9-24) with the new set (1066MHz, 7-7-7-20) creates some internal conflict that just doesn't work on this board. Other ideas would be extremely welcome.

 

I still have absolutely no idea about the failure to detect the LAN !!!

 

However, it seems to me that in changing to the new "1.60v ver1.2" sticks, Corsair may have introduced an inferior product. The old ones are dead solid and stable; the new ones certainly are not.

 

I will be returning the new sticks (to Fry's) as they are still within the 15-day return period. But I'd still like to max out to 4 gigs - anyone know where I can find a set of the old (and in my mind superior) "1.50v ver1.1" memory modules?

 

I hope this has been helpful to anyone with an Intel DP45SG motherboard!

Link to comment
Share on other sites

It is never advised to mix and match different versions of DRAM. The integer shows a different fabrication and different fabrications are never supported by any DRAM company. Yes, they might work, but they might not work. Far simpler to purchase all the DRAM at the same time to ensure the same versions, rather than separately and hope that you get compatibility.

 

Search all the DRAM sites and you will see this issue across the board (no pun intended). I understand your unhappiness but the issue is not that one set is better than another set. It is that you are attempting to actions. Firstly you are attempting to run with a four DRAM slot population and secondly doing so with differently fabricated IC's in the module kits.

 

They are "Kits" for a reason. They are matched. Far simpler to run with two kits matched.

Link to comment
Share on other sites

Yes, that's exactly what I thought I was doing - bought exactly the same boxed kit for the second set - TWIN3X2048-1333C9DHX. This is the box description of both sets that I bought, so I thought I was getting two matched sets, just as you say. My point is that what it says on the outside of the box does not necessarily mean that what's inside is exactly the same product. I'm pointing this out in hopes that others don't make the same error.:):

 

BTW, any thoughts to explain why the system couldn't see the LAN with the second set installed? I'd really be interested in learning why this happens. Everything's fine with the first set installed (I'm able to send this post to the forum), but with the other, supposedly identical set, no LAN, which for me means no Internet!

Link to comment
Share on other sites

BTW, any thoughts to explain why the system couldn't see the LAN with the second set installed? I'd really be interested in learning why this happens. Everything's fine with the first set installed (I'm able to send this post to the forum), but with the other, supposedly identical set, no LAN, which for me means no Internet!

 

That is strange. You are not overclocked? You might well have a motherboard issue and this can also be a reason why those four modules are not working together. Not supported does NOT mean will not work, it means that the company does not warrant four modules to work together. Usually, unless you have some really offshot modules, they will work together when one does the necessary setting manipulations that you have done. Be sure to document the mainboard serial before RMA. I do this with any RMA of ANY hardware.

 

I would say that the LAN characteristic is more than enough for a motherboard RMA and also that you might well find that the issue of 4 up is also dealt with in this way.

Link to comment
Share on other sites

No, not overclocked, just default settings.

 

I may be showing my ignorance (of which I have plenty), but how could it be a motherboard issue when all that changes is the memory modules?

 

First set installed as stand-alone, DIMM 0, chan A&B, everything works fine.

 

First set removed, second set installed as stand-alone, DIMM 0, chan A&B, no LAN !!!

 

That just doesn't seem to add up.

Link to comment
Share on other sites

how could it be a motherboard issue when all that changes is the memory modules?

 

First set installed as stand-alone, DIMM 0, chan A&B, everything works fine.

 

First set removed, second set installed as stand-alone, DIMM 0, chan A&B, no LAN !!!

 

That just doesn't seem to add up.

 

With the above, I tend to agree that there is some issue here. However, DRAM is passive so having the DRAM fault the LAN connection is clearly a conundrum. Have you tested the modules with Memtest?

Download Memtest86+ V2.01 from--->

and extract the ISO image. Burn the ISO image to an CD-ROM disk.

 

Test the modules singly. Test one module in the Slot 1 (Closest to the CPU). If it passes, then transfer that module to Slot 2, 3, and 4, testing each time. Now you have a single stick of DRAM tested correctly and all four slots tested correctly in single channel mode.

 

Then test a kit in Slot 1 and 3. If it passes, test in Slot 2 and 4. Finally, test with all four slots filled and your DRAM set to 1066Mhz and +.2v on the MCH.

 

Results?

 

Edit:

 

As well, should any stick error out in one slot in Memtest but complete in another slot, then there is a mainboard issue. Should any stick error out in a slot and another stick pass in that slot, then I would look to RMA of the DRAM. This is a bit intriguing from my end but very likely frustrating from your end.

Link to comment
Share on other sites

In my original post, I detailed extensive use of memtest+. However, mine is an earlier version, and I only tested the memory sticks as pairs or all four. Thus, your progressive method should be much more definitive/conclusive. I'll download the latest version and post the results. Stay tuned - may take a while !!!

 

Edit: To your instructions, I'm going to add testing each stick alone, one-at-a-time, in slot 1. Then a known good one in each slot, one-at-a-time, right across the board. Then in pairs in 1&3, then 2&4, both old kit and new kit, and mixed pairs. Then all four first with old kit in 1&3, new in 2&4, the with new in 1&3, old in 2&4. If this doesn't catch the fault, I'll seek more advice. Hope to be done before Christmas!

Link to comment
Share on other sites

OK - a few preliminary results using MemTest86+ v2.01

 

1. Tested all four sticks individually in slot 1. All four perfect.

 

2. Used one stick out of my original set to test each slot individually. All perfect.

 

3. The only interesting thing I've noticed so far is that in Memtest, right under the green logo box, it consistently lists my original memory set at a speed of 4190 MB/s. However, in the same section, it consistently lists the newer set at a speed of only 3086 MB/s.

 

As I had let the system automatically recognize the RAM, I went into the BIOS to see if changing settings would speed up the newer RAM. I changed the settings on the newer stick from 1066MHz, 7-7-7-20 (default for the newer set) to 1333MHz, 9-9-9-24 (default for the original, faster set). This brought it up to only 3448MB/s.

 

Since the newer set is also labeled (in small print on the stick itself - not on the box) at 1.6v (instead of 1.5v for the original set), I went back in the BIOS and changed that, too. Still only 3448MB/s.

 

Please remember that both sets are boxed identically - they are BOTH TWIN3X2048-1333C9DHX - I thought I was getting exactly the same thing as my original set when I bought the newer set. But, it turns out that one set is more than 1100MB/s faster than the other!

 

So, the question has to be asked - why is there such a great speed differential between two kits that are boxed the same? Is there a quality control issue here?

 

Furthermore, could it be that when I have all four sticks on the board together, the great speed differential is causing some conflict/incompatibility? Is this the root of the problems I'm having?

 

Just wanted to throw this in as a preliminary finding. I'll continue with the other tests listed in your post above.

 

Very interested in your comments.

Link to comment
Share on other sites

I fail to see how two modules running at 1333Mhz with the same timings can have such a disparity. That's like saying two cars, running at 100KPH exactly with one car far ahead of the other. Sounds like nonsense to me. :sigh!:

 

My advice for you would be to send the DRAM back and purchase another make.

 

Then you can deal with such issues with that company. :D:

 

I can say this because I am just a simple member here. Just like you, although I have been a systems integrator and an enthusiast since the days of the Commodore Vic 20.

Link to comment
Share on other sites

Well, just calling it as I see it - not making it up, those are accurate figures from Memtest86+ v2.01.:):

 

But thanks, Derek - glad to hear it puzzles you, too.

 

At this point, I'm really hoping a Corsair rep is following this thread - I'd to hear the official company response to this whole thing.:confused:

 

My first computer was a Timex-Sinclair 1000. Still have one here on my desk to remind me of the "good old days."

 

Edit: Regarding going to a different company: I've always been a fan of Corsair and have used Corsair memory on most of my past systems with no issues. I will not abandon Corsair until/unless they abandon me.

Link to comment
Share on other sites

I just retested to confirm what I said above about the discrepancy in speed as shown by Memtest86+ V2.01, and got the same results.

 

I tested all four sticks individually (as single-channel memory) in all four slots.

 

The sticks in my original set of TWIN3X2048-1333C9DHX are consistently 1100 MB/s faster than the sticks in my second set of TWIN3X2048-1333C9DHX.

 

As further confirmation of this speed discrepancy, it takes the new sticks more than two minutes longer to complete a single full pass in Memtest.

 

Directly on the back of the sticks, the original set is labeled "1.50v ver1.1".

 

In the same location, the second set is labeled "1.60v ver1.2".

 

BOTH kits are packaged and labeled as TWIN3X2048-1333C9DHX. The voltage and version numbers are the ONLY visible differences between the two kits

 

I am holding off on doing any more testing until I get further comments.

 

My biggest issue right now is that the 15-day grace period for RMA's from the retailer where I bought the second set (Fry's) is due to run out on Tuesday (11/25/08).

Link to comment
Share on other sites

  • Corsair Employees
The first thing is the memory speed is a raw number and not a benchmark you would need to test each set with a memory bench mark in windows to see the difference and if there is a slight difference it would most likely be related to the memory IC's we used on that specific version and not uncommon. If you are using both sets on one system DDR1066 would be suggested and set the memory Voltage to 1.7 Volts and set the NB Voltage to +.2 Volts and just let the BIOS set the timings but set Command Rate to 2T if it's listed.
Link to comment
Share on other sites

Hi Ram Guy:

 

I'm afraid your post was not too helpful.

 

Looking back at earlier posts in this thread, you will see that you have already suggested those BIOS changes and I already tried them. They did not help.

 

Also, I used the quick benchmark tool in Everest and found the system was slower - memory read speed down by 500MB/s, copy down nearly 1000MB/s - with the v1.2 sticks. This correlates nicely with the figures I quoted earlier from Memtest.

 

Actually, I was only suggesting the speed discrepancy as a possible reason for the problems I'm seeing.

 

Here's a brief description of those problems:

 

1. With the original set (v1.1) everything is hot, straight and normal. The system runs clean, sweet and fast with no issues whatsoever.

 

2. However, with the second set (v1.2) installed so that the memory is fully populated with all four sticks (v1.1 in slots 1&3, v1.2 in slots 2&4), I get POST failures, BSODs, and the system often fails to recognize the LAN. This is true whether I leave the BIOS on automatic, or use any combination of the manual settings you have suggested - plus a few you didn't.

 

3. If I take out the v1.1 sticks and put the v1.2 sticks in slots 1&3, the system will boot very slowly. No BSODs, but it almost always fails to recognize the LAN. As before, leaving the BIOS on automatic or using suggested manual settings makes no difference.

 

4. Interestingly, when I use a v1.2 stick alone as single channel memory, the system boots normally and recognizes the LAN. This is true of any of the four sticks. The system benchmarks slower with a single v1.2 stick, faster with a single v1.1 stick, but otherwise runs nicely.

 

5. It is only when I use the two v1.2 sticks together, either by themselves in slots 1&3, or with all four together, that here are problems.

 

6. Using Memtest86+ v2.01 in every possible permutation and combination, starting with each stick tested individually as single-channel memory in each slot and working up to the fully-populated four-stick board, there are no faults except when the board is fully populated with all four sticks. Then memtest show bad RAM at memory address 0x5834f774.

 

Comments?

Link to comment
Share on other sites

Does your BIOS allow you to adjust the memory controller voltage? Running 4 up requires more voltage than 2 up, generally speaking.

 

Also, just so we are clear after quite a few posts, have you tried manually setting the memory speed to a lower speed, such as 1066 and running 4 up at 1066?

 

What memory speed options does your BIOS offer?

Link to comment
Share on other sites

Thanks for the reply! (and great picture)

 

Yes to all.

 

At Ram Guy's suggestion, I tried setting memory voltage up to 1.8v and NB voltage +.2v (default is 1.1v, so I set it at 1.3v)

 

Also tried both 1333 and 1066.

 

I believe my BIOS goes down to 800 (?), but didn't try it. Seems this would slow the system down so much I might as well forget 4 gigs altogether and just be happy with 2 gigs of the much faster v1.1 memory.

 

The v1.1 sticks are very happy at their default 1.5v, 1333MHz, 9-9-9-24. The v1.2 sticks are not. The v1.2 sticks default to 1.6v, 1066, 7-7-7-20 (even though the box and label say 1333, 9-9-9-24) , so I've also tried resetting them to the v1.1 settings. I continue to have the same problems outlined above with the v1.2 sticks no matter what settings I throw at them.

 

I know my Intel p45 chipset is reputed to be very sensitive, so I've also updated to the latest BIOS version and chipset drivers.

 

I guess what I'm really suspecting is that the v1.2 sticks are either faulty (but why, then, do they pass memtest?) or they are somehow inferior - quality control, manufacturing, component selection, etc.

 

The v1.1 sticks run perfectly; v1.2 stinks!

 

At this point, unless there are further tweaks I haven't tried, I really think I'm probably just going to RMA the v1.2 sticks and forget the whole thing.

 

Comments?

Link to comment
Share on other sites

Cool.

 

However, because of the problems I've detailed, I'm a bit leery of v1.2, even if they are replacement sticks.

 

As I've had great success with v1.1, is there any chance I could get a second set of v1.1 if I send you the v1.2 sticks?

 

This way, I wouldn't be mix-n-matching revisions.

 

I agree that a 2 x 2GB kit would have been best, but I had already bought the original v1.1 set, and the RMA grace period had run out before I decided to upgrade the system with more memory.

Link to comment
Share on other sites

We have no way of guaranteeing a specific revision. However, we DO guarantee that a set of 1.2s will meet the spec or we will replace them. The 1.2s are not inferior, they just use a different IC. It could be that you simply have a bad set.

 

If you want to try replacing the 1.2s, start your RMA here: http://www.corsair.com/helpdesk/default.aspx

Link to comment
Share on other sites

No, In that case I think I'll just take them back to Fry's, where I bought them, and consider this a very valuable lesson. Next time I build a system, I'll get the right memory to start with! The grace period for returning the v1.2's at Fry's is still open - I'll take advantage of it

 

BTW, I see in your profile that you are a gun enthusiast.

 

My company manufactures MILITEC-1, the best gun lube on the market. If you would like to send me a mailing address in a private message, I'd be very happy to send you some. It's the least I can do for your kindness in letting me bend your ear with my problems.

 

If not, we can end it right here.

 

Thank you very much for your time and Happy Thanksgiving!

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...