Jump to content
Corsair Community

Corsair MP510 problem


Yaki
 Share

Recommended Posts

Good day, people,

 

I got problem with Corsair M.2 SSD MP510 480GB after yesterday (15 April 2020) Windows 10 Update.

 

I've been using this SSD for a bit more than a year, and everything was fine. Yesterday in late evening I found pending Windows update, so I pushed "Update and shutdown" button and finished using PC. This morning I found my PC not booting up from mentioned SSD, where Windows 10 was installed. After struggling all day, I've failed to bring the disk back to life, but at least now I can describe the problem.

 

So the problem is the SSD stopped to be recognized by Windows and BIOS. No single program or application or utility or BIOS can detect my SSD now. Previously, when everything was fine, in BIOS this device has name "Force MP510" and it was also visible from Windows utilities like Disk Management or others. Couple of hours later, after tweaking BIOS options, I made it back semi-visible, but it's name now is PHISON SSD E12, what is chipset's name and not disk's model name. So my first thoughts was like it's firmware is broken and I should probably update it. I've found Corsair SSD Toolbox app to update firmware hopefully, but I've failed. Toolbox doesn't recognize the SSD as a disk it can work with, so the button to update firmware appears gray and is not clickable.

I've been trying to install firmare (12.3) from MSI installer (found it on this forum), but it was not able to download firmare, so this trial failed too.

I've been trying to plug-off and plug-in back the SSD to M.2 slot, but that didn't helped.

I've updated BIOS to latest one (2020), as mine was 2 years old (2018), but that didn't helped as well.

 

Now, I have no more ideas how to get it back to life. I've paid ~130 EUR for it and it would be really disappointing to throw it to waste bin after only 1 year of using. So I am hopefully asking - is there anything I can do with it?

I am attaching 2 photos so you can see more details.

 

Thank you very much for your answers in advance.

bios_ssd.thumb.png.1d93a1bb83fe1135e2b753d573a240a9.png

cors_tb1.PNG.6a46d6998a5a494d0c6cad54e8aabed8.PNG

Link to comment
Share on other sites

  • 2 weeks later...
  • 4 weeks later...
  • 2 weeks later...
My problem is identical to that of friend Yaki! The same thing happened to me. I have the MP510 480gb since June 5th, 2019 and since then it always worked perfectly. Until 2 weeks ago I performed an update on Windows 10. I had not turned on the PC until yesterday (May, 31). I called, boot perfectly, after 20 seconds the screen went black. I called back and it didn't work anymore! I went to the BIOS of my motherboard (AsRock k4 Fatal1ty Z270) and the ssd m2 nvme is no longer recognized! I lost everything! I've done everything and there is no recognition of the ssd m2 MP510 by Windows 10 and the motherboard (I updated the BIOS, reinstalled the operating system on another ssd, tried another m2 slot). I know I still have a warranty period, but I live in Brazil and my SSD I bought in another country. How should I proceed? I've always had Corsair products, but it never happened to me ... I need help. Thanks in advance.
Link to comment
Share on other sites

My problem is identical to that of friend Yaki! The same thing happened to me. I have the MP510 480gb since June 5th, 2019 and since then it always worked perfectly. Until 2 weeks ago I performed an update on Windows 10. I had not turned on the PC until yesterday (May, 31). I called, boot perfectly, after 20 seconds the screen went black. I called back and it didn't work anymore! I went to the BIOS of my motherboard (AsRock k4 Fatal1ty Z270) and the ssd m2 nvme is no longer recognized! I lost everything! I've done everything and there is no recognition of the ssd m2 MP510 by Windows 10 and the motherboard (I updated the BIOS, reinstalled the operating system on another ssd, tried another m2 slot). I know I still have a warranty period, but I live in Brazil and my SSD I bought in another country. How should I proceed? I've always had Corsair products, but it never happened to me ... I need help. Thanks in advance.

Well the Corsair warranty is valid internationally so as long as you have the original receipt, you can send it into offical Brasils corsair autorized repair shops.

Link to comment
Share on other sites

  • 4 months later...

Hi Davibc, please could you inform us about the present situation of your Corsair SSD NVMe m2 Force MP510 ?? I'm also from Brazil, as you. I'll keep waiting and thanks.

 

 

My problem is identical to that of friend Yaki! The same thing happened to me. I have the MP510 480gb since June 5th, 2019 and since then it always worked perfectly. Until 2 weeks ago I performed an update on Windows 10. I had not turned on the PC until yesterday (May, 31). I called, boot perfectly, after 20 seconds the screen went black. I called back and it didn't work anymore! I went to the BIOS of my motherboard (AsRock k4 Fatal1ty Z270) and the ssd m2 nvme is no longer recognized! I lost everything! I've done everything and there is no recognition of the ssd m2 MP510 by Windows 10 and the motherboard (I updated the BIOS, reinstalled the operating system on another ssd, tried another m2 slot). I know I still have a warranty period, but I live in Brazil and my SSD I bought in another country. How should I proceed? I've always had Corsair products, but it never happened to me ... I need help. Thanks in advance.
Link to comment
Share on other sites

 Share

×
×
  • Create New...