Jump to content
Corsair Community

Recommended Posts

What layout are you using? I had the same issue. I was using the "Europe" layout in iCUE Device Settings. By sheer luck i thought of changing it to "US International". Clicked on Update... Done. And then I just changed back to "European". Check if this works for you too.
Link to comment
Share on other sites

hey buddy,


I had the same/similiar issue.

It updated once to 3.08, then I noticed double types of some keys.


I tried to force firmeware update and ran into the samme issue as you.

After an hour or so of trying different versions of iCue (even old version of corsair link) I gave up.

I had success the next day, when I installed newest version of iCue on my laptop (never had it installed there) and forced firmeware flash to the old 2.05 firmware version

(get / see it here https://github.com/mattanger/ckb-next/blob/master/FIRMWARE )


For now my problems are gone, I currently stick with 2.05 firmeware, did not tried to update to 3.08 on my computer again.

Edited by Am-Freak
Link to comment
Share on other sites

Just wanted to let you guys know that I have the same issue with my Corsair STRAFE RGB keyboard. Currently on 2.05, but when I try to update to 3.08 via iCUE it fails. An issue that I can live with, but would much prefer for it to not be there. :)


Zeliroth says firmness, good my dear friend tries to do the following way tries to enter into Network Security Mode after this start the iCUE and do the update, here I did it and it worked ok everything on the keyboard, here I was in the same failure updating.


Anything just talking does not handle a lot of things not but I followed this way a comrade here from the forum said it worked there

Link to comment
Share on other sites

Just now managed to update to 3.08 via safe mode with networking enabled. So far so gud. :D Would also like to know what this new firmware adds/changes.


You're the man :cool:. Rebooting in safe mode with the network enabled did it for me.


I haven't notice any change though, but my MX Silent Strafe RGB mark I was already working perfectly.

Link to comment
Share on other sites

  • 2 years later...

Strafe RGB


have the same problem, W10 pc starts but sometimes the pc and the iCue does not recognize the keyboard

Deintall the iCue andd delete in the regedit, and new install didnt help :-)


i think the bug comes with FW 3.08

i try to reset the keyboard, but the keyboard wpnt flashing after put in usb when hols Escape, other way

Somewhere a older FW for Download ?

Link to comment
Share on other sites

  • 3 weeks later...

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...