Jump to content
Corsair Community

Corsair Hotpot

Corsair Employees
  • Posts

    407
  • Joined

Reputation

10 Good
  1. Hi, EOL cases will have a hard time finding spare parts. That was a unique design to that case, we don't have any alts that I can think of unfortunately.
  2. The 280x does not fit a 280mm radiator up front. It can fit on top but with only 120mm fans up front as well. The 300mm GPU length is with the fans installed also.
  3. Hi, The Carbide 175r logo is transparent and it lit up by the RGB fans in the case.
  4. I haven't tested that exact GPU unfortunately. But the 360mm is with the max with the stock fans already being accounted for so in theory, the card would fit. It would be a tad snug but it should work.
  5. I don't have an image to share right now, but we've fit the A500 in the case with clearance!
  6. I think the part you are looking for is this: https://www.corsair.com/us/en/Categories/Products/Accessories-%7C-Parts/PC-Components/Cases/Replacement-hard-drive-tray-%281-unit%29/p/CC-8930040
  7. Hi avalonolava! With the case being as new as it is, spare parts will slowly come into stock. I'd check the website again to see if it's available or click on the "notify me when in stock".
  8. Hi MaGi)(ieN, I was working with Mint on this one. One thing can I have you try first is running a clean install of the latest version of iCUE which should be 3.33.246. You can PM me if you still have the same issue after. How to do a clean install of iCUE: https://help.corsair.com/hc/en-us/articles/360025166712-Perform-a-clean-reinstallation-of-the-Corsair-Utility-Engine-iCUE- iCUE Version: http://downloads.corsair.com/Files/CUE/iCUESetup_3.33.246_release.msi
  9. Do you have iCUE installed? Does this happen with ICUE closed if you do have it installed?
  10. Unfortunately it seems like a defective LED. I recommend contacting our support team to assist you with an RMA.
  11. Hello, You could cover the gaps with some electrical tape it will not harm the keyboard.
  12. Hi, Can you try unplugging the mouse. Hold the left and right mouse buttons at the same time and plug in the mouse. Let go after 5 seconds. Try that and if nothing, reinstall iCUE, could be a bad installation of the drivers.
  13. The K55 has it's presets onboard which you cycle using the FN+ the number. Otherwise iCUE uses its software profile but you cannot save them to the keyboard.
  14. You can only assign the G keys to another button or a maco using iCUE. The OS dictates the layout and you are going to be limited to that which is most likely the standard of your region.
  15. Can you try disabling the SDK option in settings?
×
×
  • Create New...