Jump to content
Corsair Community

H80i not recognised, fans jerk, led flashes, then nothing


Recommended Posts

My first post, so excuse if it's a repeat. But don't normally do this unless reached end of my tether!


I've had h80i for 12 months. Worked well, no changes to fans. But this week is behaving badly, and I can't diagnose further.



-on boot h80i flashes, fans jerk and that's it.

-bios complains no sys fan, and asks to go back to bios interface.

- interface shows no rpm on sys fan

-I override and force boot to windows load corsair link shows no h80i (system is warm but not dangerously so because pump must be working, so continue to use windows)

- fans do not spin

-One really odd thing .......I get a one off good boot first thing in morning after its been disconnected from the mains. Then it detects all and works well. If I reboot, back to same problems above.


Have loaded latest corsair link beta (2 6) but this just shows it cannot detect the h80i, though it is showing it is pumping because it's picking up the fan rate from the Asus motherboard.


I've taken out all usb connections, tried all the headers, even connected to external USB at rear with no luck. The mobo just doesn't see it.


I've no idea what to change to force it to recognise the h80i. What's frustrating is its been working well for over a year just stopped. Am convinced is a driver , firmware or configuration change/update but can't see what. ?.


Any suggestions?

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...