Jump to content
Corsair Community

VX550 Voltage Problem


Recommended Posts

I'm upgrading my old PC. Have just purchased a VX550. I haven't received my new motherboard yet but I decided to swop out my old PSU now as I'm reusing my old case. My PC started up ok but when I looked at my Smart Guardian software it said the -12v was only at -3.7v. all the others were almost smack on the correct values. I rebooted to check in the BIOS. This showed the -12v to be o.k. but showed the -5v at -61.7v. I tried to boot it up again but it failed during the first windows screen. I couldn't get it to start again. I refitted the old PSU and now it runs o.k. The BIOS and Smart guardian show the voltages on the old PSU to be generally within the current ATX spec (+/- 5 or 10%) but occasionally it goes slightly beyond these limits but only slightly.


I gather software can be unreliable in measuring voltages, but as the 2 voltages above seem to be way out and the computer won't boot surely it must be faulty. From what information I can find on the web the 20 pin connector is still the same configuration so it should work o.k.


Should I send it back or is it just not compatible with my old system? I don't fancy trying it on my new motherboard or hard drive in case they get damaged.


Any advice appreciated.

Link to comment
Share on other sites

it should fine. there is no more 5 volt ground so i would expect wrong readings.

best to test with a volt meter, your bios may not be ATX version friendly on the newer stuff.

if you really had an almost +4 volt 12v ground i dont think the PC would even boot.

Link to comment
Share on other sites

  • 3 weeks later...


This topic is now archived and is closed to further replies.

  • Create New...