Jump to content
Corsair Community

cannot install Windows 7 on Nova 32GB SSD


Recommended Posts


I am trying to do a Windows 7 install on a Nova 32GB SSD.

In the installer I am able to get to the point of seeing the drive and can create/edit partitions but when I press Next I get a general error message (sort of see install log) and the installation cannot continue.

More details:

I tried with both AHCI and IDE mode and the other drives disconnected.

I also formatted the drive in Windows 7 (NTFS default full format)

MB model: Asus P5E-VM HDMI, Intel® G35 / ICH9R.

Any ideas of what else to try?

Should I just return the drive? I mean the drive seems to work fine in Windows but somehow seems incompatible with my mobo/Windows 7.


Link to comment
Share on other sites

When you get to that point delete all partitions on the drive then click next it will partition and format the drive for you. If you have partitions on the drive Windows 7 will give that error and the install will fail.


I did that too and it's not working. I also tried creating 2 partitions on the SSD with the installer and didn't help. Again, I am able to create, delete, format partitions with the Win7 installer but then it fails for the next step.

Link to comment
Share on other sites

The drive doesn't, but the SATA ports might.

Then which are those?

(On Asus support site I didn't found anything specific, just the following which might be related: Intel® Matrix Storage Manager Driver, Intel® Chipset Software Installation Utility but neither sounds convincing to me.)

I'll try install it in another system later this weekend.

Link to comment
Share on other sites

I managed to finally install Windows 7. I'll detail in case it might be useful to somebody else:

-I updated the BIOS to the latest version but this did not help.

-I installed the drive on another machine (Gigabyte AMD 785G board) and was able to create a Windows partition properly: what I mean is that when creating a primary partition Windows7 installer will also create a 100MB system partition. This I do not remember to have happened on the ASUS G35/ICH9R board even with the latest BIOS.

-I installed Windows up to the point of the first reboot then I moved the drive to the other machine and finished the installation.


I don't think this is necessarily the right way to do it :D and maybe trying to upload drivers as mentioned in the previous replies might work also but I really don't have the time to try.

Thanks for all the replies.

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...