Jump to content
Corsair Community

H115 ELITE CAPELLIX doesn’t show up in ICue

Recommended Posts

Recently bought a H115 ELITE CAPELLIX cpu cooler got it installed and checked the connections and started it to find the pump was working but none of the 5 Corsair rgb fans moving, eventually the computer recognized the error and turned itself off and when I restarted it the 5 fans worked. After seeing it corrected its error I went to icue to find that the node or the pump head wasn’t recognized, (commander core rgb and pwm.) deleted and reinstalled Icue multiple times and repaired Icue with it still not showing up. Also noticed no rgb lights on the fans started up either when the fans ran. The problem of the computer not recognizing the fans is still frequent too. Is it the node itself or something deeper. If anyone can point in the right direction, it would be greatly appreciated 

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...