Jump to content
Corsair Community

Corsair PSU Cables Not Keyed to Match ASUS Motherboard

Recommended Posts

I have an ASUS ROG Maximus z690 Formula motherboard and a Corsair HX1200i power supply.  The cables from the power supply are not keyed to match the two 4+4 power sockets on the motherboard.  The motherboard is keyed as follows, looking down at the socket with the latch at the top.   (x indicates a square pin, o indicates a rounded pin.)

       top row                  o x x o

       bottom row          x o o x

I have tried the "CPU" and "PCIe" cables that came with the power supply:  they did not fit.

Clearly, I'm missing something obvious.  Any ideas?

Link to comment
Share on other sites

you need to use the CPU one obviously

the 8 pin side goes to the PSU

the 8 pin that separates in 4+4 goes to the motherboard.

Link to comment
Share on other sites

Thanks,  LeDoyen, for the quick relpy.  The problem is that the keying on the "CPU" cable is (looking toward the motherboard socket):

     top row                  o o x o

     bottom row          o o o x

and it doesn't seem to match the keying of the socket on the motherboard.

Link to comment
Share on other sites

that's the correct keying for the CPU sockets.

They should fit since the rounded connectors fit in square holes. but the latch is on the top, not the bottom which is very annoying

If you tried to fit it in the position that makes sense from a human (thumb down, latch down) it won't fit.. But from a motherboard engineer perspective (break your wrist, and bleed on that VRM heatsink, thumb up, latch up) it fits.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...