Jump to content
Corsair Community

Dark Core Pro SE acting weird after firmware update


Recommended Posts

Hello,

 

I already contacted Corsair per email today about this. However, I'm still curious about your suggestions and/or maybe we can do something to figure out what's wrong in a short term.

 

I bought my mouse a couple months ago coming from a Razer Mamba TE having sensor issues related to tracking and stopping recognization of any movement randomly. My new mouse worked perfectly out of the box, but after a few weeks the latest firmware update came out and suddenly it started showing issues like randomly disconnecting, shutting of and powering back on (except for the DPI profile lights if I'm right)

 

And since then, my mouse stopped most of the time with responding while booting up my pc, or it did not sync and I had to reboot for fixing it (temporary tho). With this, I'm receiving a Windows error that my usb device could not be recognized and within Device Manager I see a 'A request for the USB device descriptor failed'. Today, the mouse completely stopped working.

 

If it helps, sometimes I saw strange behavior on the charge status led while wired also. It seemed like it was stuck at that moment..

 

All this is related to a wired connection, wifi/bluetooth does not have any issues so far. Resetting the mouse doesn't help either.

Link to comment
Share on other sites

I tried different usb ports, aswell as multiple devices (Windows 10 and Linux) for the wired connection. To mention, I'm receiving the "A request for the USB device descriptor failed" error just after plugging in the cable without the mouse.

 

I sent another ticket request as a wasn't logged in when I sent it before.

My ticket id is: #2004407974

Link to comment
Share on other sites

Quick note, I tried to reconnect the USB cable with the mouse and it succeed recognizing. I could force an update, did it again as I did before as well. But think that it could be solved with a firmware improvement to fix this issue.
Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...