Jump to content
Corsair Community

Void Pro SE RGB Wireless Surround not working


sikshots
 Share

Recommended Posts

i have tried for years to get my surround to work on these 120+ dollar headphones. they have the same driver as the logitech set my brother has, but no matter how hard i try to change settings, download this, download that. re-install ique, uninstall it. no matter what i do i cannot get surround to work on them. at this point i feel i have been lied to, and these things are nothing more than stereo headphones. all i get is left and right, with some volume changing and some muffling on occasion, but no matter how many tests i do, i can never tell if something is in front or back, top or bottom. now, my brothers logi's with same exact part inside, does this task amazingly. so whats the deal corsair? am i stupid, or did you rip me off? (i have the void pro se rgb wireless, yellow ones from best buy)
Link to comment
Share on other sites

im to the point where i am looking at buying an external sound card for another 100$ to complete the task that my original purchase was supposed to do. i just dont get what im supposed to do. please tell me there is simply a driver to install or something else, as i am not made of money, infact i had to wait for taxes to even afford these in the first place. i have always like corsair as a brand due to high quality products, so i trusted in this brands claims of 7.1 when purchasing these headphones. but they are seriously only stereono matter how i try to run them, with dolby atmos, windows sonic, ique, every program i can get, and ive even paid for 1 month of one to try and get surround working. if i cant get the surround to work on these things, or worse, if i already have experienced the best 3d sound they have to offer, then i absolutely was ripped off, blah blah blah, insert useless angry customer threat of never buying again and making sure friends and internet strangers never do either. Edited by sikshots
Link to comment
Share on other sites

is there anyone who has had this problem, or even anyone who hasnt? whats the deal, i wanna know about others experience with the directional audio on this headset. ive done some research, and ive not found a single remark saying this set has good surround, specifically directional. and if its purely a software thing, the company should be able to get it to run correctly right? and also, is there anyway to get my headset to work with logi's software, since they have taken the time to properly do the job with the exact same speaker driver?

 

and lastly if nothing else works, i can get a full refund from warranty, correct? considering that my product is faulty in that it never produced anything remotely close to 7.1 virtual surround. thats warranty territory right? malfunctioning product? i just could use some answers. i simply do not have the money to have wasted $100+ on a pair or regular headphones, that arent even hi-fi. basically its starting to feel like i got totally lied to and ripped of by a major "trusted" brand. what the heck is the deal?

 

also should i write a support ticket for this kind of thing? i would but it seems not unique to me, its everyone who got these things.

Edited by sikshots
Link to comment
Share on other sites

I didn't really spend the money for the surround sound, I wasn't expecting much. But I used the Windows Spatial Surround. But I can't really tell much even with the Dolby Atmos and DTS Unbound samples.

 

However, I never really trusted those software-based surround systems I prefer to have the physical speakers.

Link to comment
Share on other sites

 Share

×
×
  • Create New...