Jump to content
Corsair Community

K68 RGB red lightning issue


Scafforth
 Share

Recommended Posts

Hi

 

 

Today I received my K68 RGB keyboard, when I received it i tried it on several computers/laptops, everything working fine using the predefined modes, (one of the computers i plugged the keyboard to, has Linux), I downloaded the icue software and started playing with effect/learning them, after a while I tried to connect it back to the Linux computer and hoping to use the predefined modes, and the leds are only on static red, I tried the combinations for the predefined modes, (fn + 1 -0) but the keys wont change and stayed static red, I also tried to do a reset by pressing fn + F4 keys for 5 seconds as the guide says, but wont do anything, it stays red, then when I plug the keyboard back to the device that has Icue, the leds show for a few seconds and then they change to the last profile I got selected, (also tried to do the key combinations in the computer with the cue software and it doesnt change to a predefined mode nor the reset), I dont know if the problem was trying to use the keyboard on a pc with Linux, I just wanted to use the predefined modes when i use Linux, also im confused about the moidel I received, as far as I know the K68 rgb comes with red or blue switches, mine came with cherry speed, the silver ones, I bought it from Amazon México, im guessing it´s a rapidfire version? the box wont say if it is a rapidfire, the sticker for the mx swtiches on the box shows Mx speed, same I got, just confused because the dust and spill resistance "ad/section" shows mx reds. I was actually hoping for blue switches, the description in amazon was weird, it had on the description: "rapídfire" and then "mx blues", prior to this I look at the K68 on Corsairs official website and it showed that the options are blues and reds. Has anyone experienced this issue before?

 

 

Sorry for the long message.

Link to comment
Share on other sites

 Share

×
×
  • Create New...