Jump to content
Corsair Community

MP600 Firmware Release Notes

Recommended Posts

HI I have question whit my MP600 m.2 NVMe M.2 ssd speed is 3.5gb/s

it is normal? not 4-5gb/s? :[pouts:


z270 (and every Intel, in fact) only supports PCIe 3.0. For full speed, you need PCIe 4.0. This is currently only available on the newest AMD platforms.

Link to comment
Share on other sites

I am in the same situation. In writing I cap at 2.5gb/s. I made an exchange and I get the same result.


Your system specs list an MP500. That's about expected as that's an older PCIe 3.0 drive. Putting it into a PCIe 4.0 slot won't automatically upgrade it.

Link to comment
Share on other sites

For those not seeing the update in SSD Toolbox. Can you try the following:


Method 1:

- Open SSD Toolbox

- Run FW update check

- If it doesn't show an available update, leave computer on with SSD Toolbox open


If after a few hours it's still not showing an available update try


Method 2:

- Open command prompt

- Type "ipconfig /release all" and press enter

- Type "ipconfig /renew" and press enter

- Open SSD Toolbox and run the FW update check


If that doesn't work, try


Method 3:

- Shut down computer

- Physically uninstall the MP600

- Reinstall MP600

- Reboot

- Run the FW update check in SSD toolbox


There's a caching oddity in Windows with the Toolbox that prevents it from seeing an updated version of a backend file that SHOULD have the newest FW listed on there.


I personally experienced this just now and was able to circumvent the issue by doing this. I'm going to attempt to replicate the issue on another system, and I'll share my findings.


Followed all steps, still no firmware. :(

Link to comment
Share on other sites

That's great to hear! Can you re-run the Crystal Disk Mark tests as mentioned in the other thread? Really want to make sure you're getting the most out of your SSD.


Hi Corsair Kevin,


Could you please provide release notes for 11.3? Thank you.

Link to comment
Share on other sites

Updated from EGFM11.1 to EGFM11.3 on MP600 1TB:


On EGFM11.1 with crystaldiskmark I was consistently getting ~500MB/s on 4KiB Q32T1 WRITE tests.


AFTER the update to EGFM11.3 I CANNOT get above ~350MB/s on the aforementioned WRITE test no matter how many times I re-run the update. This is a 30% reduction in speed for this test!


Every other part of the benchmark is well within the values I had on EGFM11.1. I should not have updated to EGFM11.3 and if you are not experiencing issues on EGFM11.1, neither should you.

Edited by beardstheticz
Link to comment
Share on other sites

  • 1 month later...
  • 2 weeks later...
@CorsairKevin & colleagues: Why is there no changelog for Firmware 11.3 , which is now distributed since months? Honestly a poor service for the very high priced corsair products. I would expect a better information management and community management.
Link to comment
Share on other sites

  • 1 month later...
I've got a problem. I have installed the latest version of toolbox on a Windows 10 Pro 64 bit system, version 1909, and it does not recognize the MP600. It recognized a Samsung NVME device, but the Corsair is wholly missing. It's not visible through Device Manager or Disk Management. No Windows events either. Funny thing is, the motherboard's BIOS (ASRock X570M Pro) sees the device and I can format it using a BIOS tool for NVME devices. BIOS sees the MP600 whether it is in the first NVME slot or the second, but Windows, dead. ASRock told me to find the device in Disk Management and format it. I don't think they bothered to read my trouble ticket. I have a ticket open with Corsair also, but have not heard anything yet. I'm on the cusp of returning the MP600, and would appreciate your thoughts before I make that decision.
Link to comment
Share on other sites

  • 5 weeks later...
  • 3 weeks later...

is there a way to update the firmware in a RAID-0 config? my two MP600 have respectively EGFM11.1 and EGFM11.3 firmware


the toolbox as mentioned above doesn't see it - it is messing with my OCD ;-)

Link to comment
Share on other sites

  • 2 months later...
This topic is now closed to further replies.
  • Create New...