Jump to content
Corsair Community

Sidetone not working in new VOID Pro RGB


Recommended Posts

Well, you can imagine my frustration, new headset, read the hype and took the plunge and bought it. Void Pro RGB 'USB'.


The sound quality is excellent however my Sidetone feature doesn't work (a reason why I chose this product).


Attempted remedies using Win10 Home


1: Reinstalled ICUE (latest version 3.18.77)

2: Updated firmware (FW 0.01)

3: Followed the instructions on the setup to the letter...

4: Tried different USB ports

5: Tested Mic (works)

6: Reinstalled drivers

7: Ensured that Void pro is set to default both Headset and Mic!


The only thing that give sidetone feed back is 'Listen to device' in the Recording tab, but its delayed, has an echo and cannot be volume controlled.


I dont know what else I can do but sent it back and purchase a new headset from a different brand.




EDIT: Just testing the headset on a Win 7 system, still no Sidetone. I suspect its broke!


On my current system the Drivers in Device manager display: MS 10.0.18362.1 a Microsoft Signer, same with the Mic. Not Corsair!

Edited by Caldwell
Link to comment
Share on other sites


  • Create New...