Jump to content
Corsair Community

Corsair VOID Wireless battery troubles.


Recommended Posts

Solved: Reflashed the firmware for the headset, it now displays the battery levels correctly.



I recently returned my first VOID Headset and got another one after being instructed to do so by tech support. The day before it stopped working, the CUE software told me the battery was at 5% after it had fully charged, and it did work for most of the day before shutting off. The next day, it would not power on, which is when I called in my problem. This new headset seems to have the same problem. I plugged in the headset about three hours ago, and waited for it to fully charge before unplugging it and turning it on. The CUE software now states it's at 15%. I don't think that's the case, and am wondering what the problem is and if there's a way to fix it other than going back to the store I got it from (it's 20 miles away), and replacing it yet again.


I hope the fine people of this forum might shed some light on if it's something I'm doing, or if I am just getting bad headsets from the store.

Link to comment
Share on other sites

Have you tried a different charging cable (microUSB) and USB port or possiblly a phone charger (Output: DC 5v)?

I have not. I got the new headset (and cord) on December 15th. It's not at all damaged or otherwise not functional.

Is the LED closest to the headset lighting up when you plug the cable in?

The LED comes on, and works properly. The CUE software is still saying 15% charge. Something somewhere is messed up. It's been hours since I posted.. it's still at 15% with constant use. Something is wrong and I don't know what.


The wait is over, and I got a hold of tech support. Apparently reflashing the firmware was all it needed.

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...