Jump to content
Corsair Community

Corsair 860W AX860 and 2TB SATA Harddrive Problem


Recommended Posts

Hey guys, first time post-er, not sure if this is the right place but here goes


I built a pc about 4-5 months ago and I've had this problem since the beginning and I've narrowed it down to 2 possibilities (took a while due to college). Just want to ask if anyone has had or heard of this problem and any fixes that might work


PC is assembled and working, OS is installed on my SSD (works fine), however the Harddrive doesnt work when connected (I've tried replacing it 3 times and still not working as well as tested it on other machines, the HD is dead each time), I believe it may be the power supply blowing the HD when its connected.


Has anyone had this problem?









Possibility no.2 - it could be the motherboard (that's a different manufacturer and I'm contacting them aswell to see if they have had this problem)


Thank you for reading and all help is much appreciated


Link to comment
Share on other sites

what are thew specs of your pc? have you overclocked anything?

how many drives, cd & HDD and usb devices do you have?


i've had a few wd drives die on me recently, one of which is the same as the one you've mentioned. i also have the same psu

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...