Jump to content
Corsair Community

K90 Launch URL / Steamgame


Recommended Posts

  • 5 weeks later...
  • 1 month later...

I don't have a K90 so I'm not 100% sure on what works or not.


If the Vengeance software supports .EXE files and you can add extra commands via that, I think you can get it working by telling the bind to run Steam.exe but add

-applaunch AppID


So for example

For Call of Duty: Modern Warfare 2:

D:\Program Files (x86)\Steam\Steam.exe -applaunch 10180

This will run steam then run the game. And if it is already running, It will launch MW2.


To find the Application IDs, Go to the Game's Store page, At the URL it will show the ID.


For example

Call of Duty: Modern Warfare 2:



The AppID is 10180, The ID will be after ""app/"

Link to comment
Share on other sites

Well there's a new suggestion, They should update the software to allow the user to add extra commands the the .exe file. That way, it should allow you to launch your Steam games through one of the G-Keys. I'm guessing they locked the File type as .exe to allow make it easier to select instead of typing.


What file type does the profile export as?


if it's .XML, Open it with Notepad and see if you can find the setting for the assigned Key and steam directory. If its there, manually add the commands then try Import the profile and save it to the K90. See if it works.

Link to comment
Share on other sites

How about creating the start menu / desktop shortcuts for each game.. then assigning a shortcut key sequence to each game and then assign the appropriate shortcut to the G keys?


Edit: Just tested the theory by creating a desktop shortcut for one of my steam games, right clicked the icon and set shortcut key <ctrl><alt><a> then assigned that key sequence to the G key and now it loads the game whenever I press the g key.

Link to comment
Share on other sites

  • 5 months later...
  • 1 year later...

So, here i am again after 2 years and still with no steam games on my G-keys.


Now i have another problem because i want to start a batch as administrator but this is also not possible.

That is because the "Run as administrator" in shortcuts is being ignored because the shortcut itself is being ignored from the corsair program.

It is the same reason URLs dont work because the software wants to jump directly to an exe file.


The shortcut trick from "Ardalista" is nice but not practicable when you have lots of programs.

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...