Jump to content
Corsair Community

SP2500 - Control Pod Issues - Common or Just Bad Luck?


Coranth

Recommended Posts

Hey folks, Coranth here,

 

I'm looking to order a set of the awesome Corsair SP2500 speakers from ITSDirect when they arrive in stock, but I've been slightly put off after having seen a couple of threads here where people have reported issues with the little TFT control pod failing; either it goes black and doesn't work at all, or turns completely white (perhaps a sign of bad caps?). I'm not looking to slander or badmouth Corsair's rep here; I just want to know - before I buy - if this is a common problem with these speakers, or whether some folks have just had bad luck and gotten a "faulty"; which, unfortunately, can happen from time to time...

 

Thanks for your help.

Link to comment
Share on other sites

Ive been unlucky with mine, after only 6 weeks I have a blank white screen.

Been waiting for nearly a week now just to get my RMA approved and am going through a bit of hassle with customer services in getting a replacement. (see here - http://forum.corsair.com/v3/showthread.php?t=95539&page=2) Abit annoying as Corsair support is usually top class.

 

Others have reported that even the replacement pod has failed!

 

Such a shame as the speakers them selves are brilliant, easily the best speakers Iv'e had.

Link to comment
Share on other sites

Masaiman,

 

Maybe this might help: http://www.karosium.com/2009/11/tft-monitor-repair.html When you get the replacement Pod, you should try to open up the faulty one and look inside it; see if there are any damaged capacitors or something like that. That might be the problem, since the 'white screen' seems to be a common issue with TFTs (and the control pod has a little TFT screen.) It's such a shame that the speakers seem to have this problem. Oh well; I will still buy them anyway; maybe I'll end up with a good set without this issue. I hope so... About the speakers being brilliant; I've read enough reviews to know that they're definitely deserving of that praise!

Link to comment
Share on other sites

  • Corsair Employees
There was an issue with production that was corrected and some units got past QC. Just request an RMA and put the pod goes blank or green in the description and we will replace it.
Link to comment
Share on other sites

  • 2 months later...

Ram Guy, I need a little help, I to am a victim of the WSOD on the desktop controller. I have requested an RMA over 24 hrs ago and received no response . I did turn the system on this morning and it was working fine for about ten minutes then went right back to the WSOD. I would like to know the status of the rma. and why, if they have identified the bad batch they dont send them out based on serial numbers registered. It is a pia to have to box up, make an extra trip, then pay to send back the defective controller, at a minimum send the new one with a pre paid return kit that we can send the old one back in.

 

On a seperate note the customer service contact page is all messed up I have been trying to get a hold of them, reference longer cables for the satellite speakers, they are just way too short unless you have the subwoofer on top of the desk or you have a really short desk, this is another issue that should be comped to those requesting them. Other than thos issues I can say this system ROCKS...

 

V/R,

Nick

Link to comment
Share on other sites

RAM GUY,

 

Perhaps you could help me with a similar situation?

 

I requested an RMA for the white LCD problem on 7/21. It took a week to get it approved (7/28) and I sent the defective POD priority. It was delivered 8/1, and acknowledged by Corsair as received on 8/2.

 

I haven't heard anything in the two weeks since.

 

I've been patient but I finally broke down and bought a different speaker set for the computer over the weekend as being without audio for three weeks is simply too long for the multimedia work I do.

 

I do, of course, need the POD back so I can decide whether to sell the SP2500 or return my new speaker set.

 

My case number is 2159105.

 

Any help would be appreciated!

Link to comment
Share on other sites

Hi RAM Guy,

 

Could you please look into my case too? I haven't heard anything back yet, only that the pod has arrived, but after a week I haven't heard anything.

 

Case #2190457

RMA #1246392

 

RMA Issued On: 8/9/2011

Defective Parts Received on: 8/12/2011

* NOTE: it may take up to 24 hours for this date to be updated after arrival at Corsair

Part Number Received: N/A

 

Thank you very much!

Link to comment
Share on other sites

RAM GUY,

 

Thanks again for your help. I got an e-mail this afternoon that the pod shipped later that evening after you contacted customer service and it should be here tomorrow.

 

This was my first RMA with Corsair so I wasn't sure what to expect. A month is too long to go without use of the speakers, which weren't inexpensive, since I had to wait for the RMA to be approved and then send the defective pod in first. Some communication explaining the subsequent delay would have gone a long way towards setting my mind at ease.

 

I hope this was an aberration, though, and all's well that ends well. If the replacement pod remains functional, I will remain happy with my purchase.

 

Thanks for your help in seeing this through and getting the ball rolling. I'm looking forward to having use of this great set of speakers once again.

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

Guest
This topic is now closed to further replies.
×
×
  • Create New...