Jump to content
Corsair Community

32GB Flash Voyager - Not Recognized


brownray1

Recommended Posts

I'm having a problem with a new 32GB Flash Voyager drive that is most irritating. I've tried it on 3 computers with the same result (Vista laptop - Dell E1505, XP laptop - ThinkPad T42, XP desktop - Dell.

 

The first time or two it's used in a usb port on the computer, everything works fine. From the second or third time onward, when plugged into the same port, I get a message that states "USB Device Not Recognized. One of the USB devices attached to this computer has malfunctioned and Windows does not recognize it".

 

If I change ports or computers, it's recognized again for the first one or two uses, but then it's no longer recognized on that port. Eventually I run out of USB ports and the drive can't be accessed. Rebooting with the drive removed does not clear the issue for any port. Rebooting with the drive inserted clears the issue for that particular port, but the cycle starts over again.

 

Also, other flash drives are recognized and can be accessed when the problematic drive is replaced.

 

I've formatted the drive and ended up with the same results. Ideas please?

Link to comment
Share on other sites

  • Corsair Employees

Can you test the drive on another system and see if that some issue happens.

Also this may apply!

I would check this link as it seems to be a common issue with Vista

 

This seems to work as well.

Go to Local Disk ©, got to Windows, got to System32, go to Driverstore, go to Filerepository, go to usbstor.inf ( click the on that is newest), copy the usbstor.inf and usbstor.PNF files. After you have copied the two files got to Windows, inf folder and paste the files in that folder. Now your usb devices (flash drives, hard drives, ipods, etc.) should work. But you may need to remove the listed device for the non functioning device and restart the system.

Link to comment
Share on other sites

The driver update did not resolve the issue with Vista SP1 or the XP SP2 laptop previously tried. A couple of coworkers tried the drive on their XP SP2 ThinkPads with the same results that I'm having - the drive was recognized and accessable twice and from then on unrecognized.
Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...