Jump to content
Corsair Community

Corsair Forum not working

Recommended Posts

I'm sure this is probably the wrong place to post this, but there doesn't seem to be any option to bring forum problems to Corsair's attention. So here it is.

Tried to login to the forum today and clicking the "Sign-in" button takes me to this link, but displays a completely blank page.


That's it, can't do anything else, stuck there. Refreshing doesn't work, rebooting Firefox (and the PC) don't help. Turned off the two browser addons I use and that didn't help. Latest version of Firefox at this point (v123.0), 64bit version on Windows 10.

I've managed to login using Edge *ugh* so have managed to actually post. But it should work in Firefox.

Link to comment
Share on other sites

Nope nothing unusual, it's worked in the past (probably a couple months since I visited). Just yesterday (after upgrading to 123.0) it sits at a blank page instead of redirecting.

Posting with Edge again, since it's still not working for me in FF.

Link to comment
Share on other sites

This topic is now closed to further replies.
  • Create New...