Jump to content
Corsair Community

iCue 5.8 and 5.9 KVM Incompatibility


Recommended Posts

Went through a lengthy email exchange with Corsair support and eventually got elevated up to a Technical Support Team Leader who suggested I post this here to be reviewed by the iCue specialists.

Long story short, I have been using a TESmart KVM (HKS0802A1U-USBK) for about two years with no issue. The KVM causes no problems when running iCue 4.33.138 and had no problems on iCue 5.7.  When I updated from iCue 5.7 to 5.8, iCue would just instantly crash on launch. After a month of trying to resolve it, I updated to iCue 5.9 and still had it crash instantly when I tried to start the app. After much trial and error (fumbling through the xml log files and piecing together that there was an issue with handling USB device address spaces), I started removing USB devices one at a time and eventually determined that the crash was caused by an interaction with the KVM and iCue software.

To prove this, I had iCue 5.9 up and running, removed all other devices plugged into the KVM, and plugged the KVM USB cable into my PC (once again, nothing else was plugged into the KVM). Sure enough, iCue crashed instantly just by connecting the KVM itself. I was able to repeat this three times. I had a support ticket (2006560475) and I sent in exports of my debug logs, and the results from CorsairWindowsReporter before and after producing the crash. I'm hoping someone can on here can look into the issue and try to resolve it in a future patch.

Please note that the real problem here is not that iCue cannot control Corsair devices connected to the KVM. The issue is that iCue cannot run at all if a USB compliant device made by another company is even connected to my computer. This bug makes my $300 KVM useless regardless of what devices I want to connect to it.

  • Like 1
Link to comment
Share on other sites

I think I am having the same issue. I have had my K-100 keyboard and Nightsword mouse connected through a USB switcher for over a year without issue. All of a sudden this morning I turned my computer on (after the most recent icue update) and icue immediately crashes. Every subsequent restart of icue crashes as well. I have tried doing a repair with icue and while it says "repaired" the issue persists.

I am going to try and direct connect the keyboard/mouse to my PC to see if it is indeed the switcher being the "issue" but if everything was working and only an icue update being the one that messed this up, I won't be too happy as I run my PC and work laptop and would REALLY not like to have to get a second keyboard and mouse just to make up for Icue's monkey wrench breaking something that was working just fine. 


Edited by CLValentine
Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...