Jump to content
Corsair Community

iCUE not detecting Lighning Node Pro and Commander Core

Recommended Posts

Some time ago I noticed that iCue was crashing a lot and tried reinstalling it. I deleted old version and downloaded 5.5
During istallation it says that it will install modules for Commander Core, Lightning Node Pro and Vengeance Pro. But after installation is finished it seems to be detecting only the memory.
When checking for Software Updates there are both Commander Core and Lightning Node available. Both are also visible in devices in Windows.

I believe that before reinstalling all of those were detected.
I tried changing USB ports that those are connected to and reinstalling software multiple times but it doesn't help.


Zrzut ekranu 2023-08-22 001453.png

Zrzut ekranu 2023-08-22 001546.png

Zrzut ekranu 2023-08-22 001711.png

Edited by Zysiu
Link to comment
Share on other sites

If you are using the Commander Pro's USB Passthru you shouldn't. It does not provide power. I had to purchase a External Powered USB Hub. Connected to my M/B and all works great.

If you can revert back to iCUE V4.33 as that's the most stable. I installed V5.3 and my AIO started disconnecting so much it was driving me crazy. Went back to v4.33 and all is fine. v5 is a buggy mess

Link to comment
Share on other sites

Commander Core is connected via SATA to PSU and via USB straight to the motherboard, same with Lightning Node Pro.

I tried reverting back to v.4 but the issue is still there.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...